Viewport spinning buttons not working

Hello there, I’m currently building a little side project where I’m trying to do a plane spawner.
I was gonna have some arrows on the GUI that allowed you to spin the plane around to have a look at it before flying it.
However, after implementing an easier way to add in planes without having to rewrite some code, the script stopped working, I tried changing when the :getChildren() function happens but that didn’t help at all, here’s the GUI and the scripts in question.


Plane Spawner section handler

Plane spinning handler

EDIT : Here’s the explorer tab things



have you tried getdescendants?

Gonna try doing that right now, I’ll update you if that worked

1 Like

Nope, didn’t work… Still doesn’t spin.

so where’s the main part of the script that’s does the job of that?

Basically subdivided into 2 sections, one of them spins the plane towards the left, the other towards the right, you can easily see them by looking at the MouseButton1Down functions

is there any errors or could you at least do some debugging, checking it prints everytime they click or smth. As well check if the camerapart/viewport is all set up properly you know,

Nope, no errors… And the camera and viewport is all set up, I got it working earlier when it was just for showcasing but now it’s bugged.

does the plane even shows up in the viewport, maybe first try and focus on fixing that first and then you can go ahead fix the issue with the arrows thing.

Nope, plane shows in the viewport just fine, only issue is spinning.