Viewport's camera subject not working

For some reason, camera subjects in viewports dont work, I put the viewport’s current camera as a camera, then i put that camera’s camera subject as a part inside of the viewport, for some reason the viewport’s camera doesnt do anything, it doesnt even look at the part. i even tried putting the viewport underneath a worldmodel, and still nothing works. can someone help me out?

1 Like

IIRC it sometimes doesn’t take the camera you set when selected from studio, I think I had to create the camera and the the Viewport to use that Camera from the script instead.

Did you position the camera to look at the subject?

Shouldn’t the viewport camera already look at the subject? if you were to do that in workspace and set the camera to a random part, it should look at the part you set it to.

Maybe try setting the camera type to watch?

I’ve tried setting it to every camera type, for some reason it still doesnt work.

If it doesn’t work then, manually position and orient the camera’s CFrame. Since CameraSubject only sets it subject and not automatically set its CFrame.


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.