VIP server "Join" button failing for iPad users

Multiple users are reporting that, when using an iPad (uncertain which one as of right now, maybe all) in our game Adopt Me the Join button for VIP servers isn’t doing anything.

This report has a lot of replies saying other users are encountering the issue, in a variety of games.

Some replies indicate that they get this on all of their iOS devices, but nobody on our team have been able to reproduce that.

The first report we got of this was on June 2nd at 1:17pm, and we’re seeing reports today.

12 Likes

I can confirm this too. My friend yesterday couldn’t play vehicle simulator on a VIP Server (on Ipad ios)

1 Like

Same. I tried this so much. It took me about 25 minutes to get into it. I actually got mad at this.

1 Like

@PeteyK473 It does this for normal servers too. When you tap a “join” button on ANY server it activates the bug.

2 Likes

Is this also happening on IPhones too? Or just iPads, and if so what iOS?

3 Likes

I tried this on an iPhone 7 Plus on iOS 13.5 and it works as expected.

This bug is centralized towards iPads running the latest version of iPadOS.

1 Like

This bug is also happening to my iPad, you have to scroll to the servers section of the game and join the VIP server from there.

1 Like

I have the exact phone, funny right. But yes, this problem is occurring a lot, for me yes on iPad, but like @DevHumor this happens really only on iPad.

1 Like

Any VIP link I click on on my Android devices just brings me to that games page. This is extremely irritating as I can’t play in VIP servers. This has been happening for years and for some reason Roblox hasn’t done anything about it.

More info I got from someone experiencing the bug:

This is a video of what it looks like when attempting to click the Join button on any servers:

But this bug not only prevents you from clicking the Join button on any server, it also makes it impossible to join a VIP server by any means - even if you go to someone’s profile and try to follow them from there, it doesn’t work. (And of course, VIP server links have been broken on mobile for years, so that’s not an option either)
If you try to follow someone into a VIP server, it just gets stuck on this loading screen forever:

Apparently this also happens if you try to follow a random person (someone you’re not friends with/following/followed by) into a public server.

This person is using an iPad (5th generation) on iOS 13.4.1. The bug does seem to only affect certain devices and not others.

3 Likes

Thanks for reporting this and providing some videos. We’ve started taking a look this morning. We know that this is happening on certain iPads and we hope to have a fix out soon.

Will also add, we’ve been looking into VIP server issues on mobile more broadly.

4 Likes

We’ve heard reports that things are working fine now, people will reply to this Tweet with the name of their device if it’s not working for them :slightly_smiling_face:

Appreciate the speedy fix!

2 Likes

@PeteyK473 Thank you very much!

Not really, as Cindering showed,there is a bug when you join roblox on small device, if the game is full or you cannot join anyone, it just bugs the roblox UI when you join.

(Edit) this does work if you go in servers but doesn’t if you try and join directly from friends tab.

This glitch is not resolved on my device yet, I’m using a I pad mini updated to the latest iOS software. I can not join anyone’s private server. (I verified that they invited me)

1 Like

We stopped hearing reports of this a couple months ago, marking as fixed :smile:

1 Like