VIRUS! I cant fix it

I made a game with a couple free models.

I found a virus asking you to donate to someone.

I’ve tried donating 5, then looking at my purchases, it just leads to a group, so I checked everyone’s inventories but they were all private!

After that, you should include more details if you have any. Try to make your topic as descriptive as possible, so that it’s easier for people to help you!

I’ve looked everywhere for the script/GUI but I can’t find it!
Game: 🏝 Chill Island (Update!) - Roblox

Any ideas on how I can find it? I mean I’ve tried a couple of plugins to scan the game but none of them work.

1 Like

Okay, first, never donate or give them any money. Second, go to the view menu:
Click Find All/ Replace All

Search for “Prompt” and “MarketplaceService”
Open the scripts. And on the top, right click to find them within the explorer, and delete them.

Adding on, these are specific terms for viruses to look for:

What you’re looking at is a simple product prompt. Not a real virus.

Also, check Players.PlayerGui for the gui, not StarterGui.


Ouch. Anyway, I don’t know how to fix it, but I recommend using as few free models as possible. They are usually loaded with viruses. I had this problem before, where you are linked to another game. I hope you can fix this. ^^

Hello, I just joined your game to see that.
Try to find a script with a “require(id)” then delete it then check if its still here. Check in the StarterGui if there’s a donation gui, check replicatedstorage and workspace too.

If you don’t find the script which add the donation gui. Join the game on roblox studio, go in Players/YourPlayerName/PlayerGui get the name of the added GUI then create a local script in startergui :

local gui = script.Parent.NameOfGui

Thanks! I’ll try this!

(finishing the characters minimum)

1 Like

In Roblox Studio the GUI doesn’t show up.

When you join the game in roblox studio go in Players/YourPlayerName/PlayerGui, you’ll find it. The game can’t display a gui outside of this folder (PlayerGui)

EDIT: The GUI doesn’t show up when you’re in roblox studio? Well, i have an idea but it would be too complicated. (Get the gui name in the game not roblox studio with Dex Explorer, you can get it in the toolbox on roblox studio)

If you press CTRL + Shift + F, you can search through all of your scripts for require, getfenv, and env, which is what most backdoors use 99% of the time. Some requires are not malicious, therefore they’re worth investigating and testing before permanently deleting.

Furthermore, if you send me the game file I can search more thoroughly for you.

1 Like

no virus

I just can’t find it! All of those GUIs have no viruses in them

Nope. Can’t find it at all.

Try to search the GUI or a script that create the GUI on workspace, replicatedstorage.

Hi, I use this plugin to scan for viruses in my games. It doesn’t get rid of ALL viruses, but you can give it a try to see if the one you’re having trouble with gets removed. You may want to make a copy of your game and test it with this just in case anything goes wrong (It’s best to back up your game when testing stuff like this)

In your screenshot there’s no donation gui

Thank you, I’ll try Ro-Defender!

Zero Viruses were found :frowning:

Hope you’ll get rid of this, and keep us updated.

Thank you so much for helping, and I will keep you updated!

Well, another simple way to find any malicious script is to search “scripts” in the search bar of the explorer and check if a model has a script that is irrelevant to the model, like if your Model is a Still Object that does not perform any function, remove all the scripts from that model.

But you need to make sure the script is completely irrelevant before removing it.
Usually, malicious scripts have weird names (like “Vaccine” or some weird numbers) and you can identify them easily, but not all scripts are.

If you think a model does not have any malicious script, then go through all the scripts and check for any suspicious code (you need to have the basic knowledge of Lua Scripting)

Check your plugins and models.

I spent 2 whole hours doing that :frowning: