Visual Tool Equip Bug

Really simple bug, just very annoying (especially in my game, looks awful because players will sometimes have one tool equipped for a long time).

When a player joins a game, any tools currently equipped by any other players will not be held up by their arm as shown by this pic:

This resets back to normal if the player un-equips then re-equips any tool:

I would love a fix because I can’t really find a non-hacky work around. Sorry if this is a known bug, I couldn’t find any mention of it anywhere.


This is an issue with animations that are already being played not replicating to clients who join afterwards

I thought there was a fix out for it but I’m not sure


I though it was fixed as well, but this may just be an edge case that wasn’t fixed. In this case, the animation wouldn’t be playing while the client joins – it would have already finished. Since it’s not playing, I wonder if that’s what prevents it from replicating.

I have trouble believing this is an edge case. In the pictures shown above, I created an empty place for the demonstration. It’s just a Tool with a Handle inside of it in the StarterPack. Nothing else is happening.

There is nothing wrong with your repro. Edge case, as in non-obvious use case that was missed in the initial pass for resolving the problem. The primary use case for replicating playing animations was long, user-made animations that were currently playing when the user joined the game, so ROBLOX tools may not have come to mind when the fix was developed. This does not mean it shouldn’t be fixed, but rather it wasn’t obvious that the issue extended this far.

You’re right! I thought the problem was specifically with tools, wasn’t aware it was an issue with anything animation related. Hopefully there will be a fix soon.

I just tried to reproduce this but couldn’t. repro.rbxl (19.2 KB)

1. Start a test server with a single player
2. Equip the default sword on the first test player
3. Add a new test player by going to the server window and pressing Alt+F7
4. The sword will be held properly as viewed by the second test player
5. From the server, set the first test player’s CharacterAppearanceId to 1273918 (or any R15 avatar)
6. Reset the first test player and re-equip the sword
7. Create a third test player
8. Sword will still be held properly as viewed by the third test player

This test shows that the default tools’ equipped animations are fine when joining after the tool has been equipped, and that it is not dependent on R6/R15.

Can you upload a rbxl file that demonstrates this bug using the repro steps I provided above?

The animation problem happens in my game, too. New players don’t notice the statues in my game’s lobby are animated because the statue’s animations don’t load for them until another animation is loaded into the statue.

I just tried my version of the test place I pictured above and the bug only happens through the website (not studio testing). That same place file I made worked fine in Studio testing.