Walkspeed broken

i was making a crouch system for my game, when i realized that the walkspeed would cap itself to 16 everytime no matter what i tried disabling all scripts and checking if i have a virus inside my studio, i found nothing and its still capped at 16, it only works on one specific game if somebody knows why this happens please give me a solution

This sounds like the doing of a Script.

However, just to make sure, if you publish the game to a new place, or clone it to a new project, does it fix the problem? If it doesn’t, then the issue must be caused by something inside the place.

i disabled all scripts passed it onto other games and everything and it still doesnt work, i know its not a client problem since on other games it works as intended

What exactly happens when you set it manually? Does this only happen when the game is running, or are the WalkSpeeds of humanoids capped during edit mode as well?

it shows the value i input but it still acts like its still capped on 16

So it’s not that it is capped, but that the character moves slower than it should?

its supposed to move slower but it doesnt i even tried setting the walkspeed to 0 and it would allow me to walk freely
Edit: i no longer have problems with it for some reason (thanks for the help though)