Warning intermittently prints in output about a rejected promise in core scripts when playtesting


When playtesting in Roblox Studio, the following warning is printed to the output window:

00:21:52.923  Unhandled Promise rejection:

-- Promise.Error(ExecutionError) --
CoreGui.RobloxGui.CoreScripts/FaceChatSelfieView:281: attempt to index nil with 'FindFirstChild'
CoreGui.RobloxGui.CoreScripts/FaceChatSelfieView:281 function updateSelfViewButtonVisibility
CoreGui.RobloxGui.Modules.Settings.getCamMicPermissions:90 function requestPermissions
CorePackages.Packages._Index.Promise340.Promise340:175 function runExecutor
CorePackages.Packages._Index.Promise340.Promise340:175 function runExecutor

Promise created at:

CoreGui.RobloxGui.Modules.Settings.getCamMicPermissions:275 function getCamMicPermissions
CoreGui.RobloxGui.CoreScripts/FaceChatSelfieView:405 function getPermissions
CoreGui.RobloxGui.CoreScripts/FaceChatSelfieView:2027 function Initialize

CoreGui.RobloxGui.Modules.Settings.getCamMicPermissions:275 function getCamMicPermissions
CoreGui.RobloxGui.CoreScripts/FaceChatSelfieView:405 function getPermissions
CoreGui.RobloxGui.CoreScripts/FaceChatSelfieView:2027 function Initialize
  -  Client - Promise340:1849

It appears to be an issue in CoreGui scripts. This just started happening. What I expect to happen is that the warning from CoreGui does not print. Furthermore, I am not the only one experiencing this since someone opened a thread about this in Scripting Support: New Roblox Update Error (Promise340)

Field Value
Issue Area Studio
Issue Type Unknown (Face Tracking?)
When Noticed Today (1 Aug 2023)
Frequency Intermittent
Impact Minor/Moderate


Log/dump files were attached to the internal ticket by a Roblox Staff (@Focia19), due to the sensitive information they may contain, will not be shared publicly!


Hello, @Maelstorm_1973! :wave:
To be honest, I am experiencing the same bug in my Roblox game. This bug is not happening to all of my Roblox games, but only to a few of them. I want to say that a template (baseplate), for example, without any kind of script doesn’t cause this bug, but on my Roblox game that contains scripts, this bug is happening. The worst thing about that bug is that it makes the scripts (local scripts) of the game not work! Like, I have a local script with over 1000 lines, and it only works in the first 300 lines? I want to say that after 300 lines, it doesn’t read the script. So with a few words, this new bug doesn’t let me develop my own Roblox game, and to be honest, that is pretty sad because I was trying to develop it for over 6 months. Also, I don’t think there is a way to fix this, only Roblox developers (Roblox staff) could fix it, and we have nothing to do. If we can do something to fix this new bug, please let me know! The bug started happening after the latest update.

@Katastro5 :cool:


We can’t fix it since it’s in core scripts. It seems to have something to do with the new face capture feature. Considering that the feature won’t work without them fixing this, they will be fixing it.

Hello, @Maelstorm_1973! :wave:
You are correct, we are not able to fix a core script, so we must wait until they fix it. The new face capture feature broke Roblox, but at what cost? Like, who asked for that feature? Anyway, we must wait until they fix it. Please let me know if the bug has been solved!

@Katastro5 :cool:

1 Like

As the camera feature has not rolled out to me (I assume), I do not encounter this issue on local place files.

I recommend you change the notifications to Watching on this topic to receive immediate updates.

Hello @SubtotalAnt8185! :wave:
Thank you for your suggestion. I had forgotten that I could make this forum “Watching”. By the way, with the camera feature, I encounter some issues, like the script working, but it is bogus, if you know what I mean. Note: Team Create is off, so no one came and messed up with my script. I also got a security pin on my PC, so no one opened it, and I also have a password and a 2FA on Roblox, so yeah. By the way, if you find anything else about this studio bug, please mention me in a post reply or just message me. I really need a solution to fix this.
@Katastro5 :cool:


Because you posted a reply, it should automatically be watching. What problems are you experiencing in your game? So far, it’s just a warning about a specific feature that hasn’t been rolled out yet. As such, it shouldn’t be affecting anything…yet. At least that’s my take on it.

Hello, @Maelstorm_1973! :wave:
I am trying to be as active as possible on this specific forum because the bug must be fixed or else it will be really difficult to develop my own Roblox game. My Roblox game is not ready, and as you can understand, I am only using “print(”“)” so I could test my game and use the console like 99% of the time. When there is an error or a warning of 25–50 lines, the console is getting pretty messy, and it is making it hard to see if the game works or not. That’s what I meant here.

@Katastro5 :cool:


I am having this same issue. However, it is preventing my games from even allowing me to test play them in studio.

This is even happening when I create a new place, and simply click play. It won’t play and gives this.

I think the issue involves studio being out of date, and a VR device.
Earlier today I tried to use studio, but kept getting the error.
So I stepped away from my computer and forgot about it.
Later, I wanted to show my nephew something I was working on, got in studio and the error happened again.
So I thought… must just be a studio thing, so I published the place to Roblox, went to the website, and played the game…
blank black screen.
so I exited, and tried it again, and a third time, still just black screen.
Then I realized, my kids had left the VR plugged in.
So I unplugged the VR, and tried from the web site, and the game played correctly.
So then I went back into studio, and started a new place, and tried to play test, and it worked.
I then tried to load my game in studio, and studio did an update.
After the update my game played in studio
So I then plugged the VR back into the pc, and tried again
and studio worked.

So it seems that removing the VR got it to working, and forced a studio update, and now its all working.

The thing is, my Studio is up to date, and I am not using a VR device. I have never used a VR device and I don’t own one, and the warning is still printing for me. It doesn’t print all the time though, which is strange. They did make a ticket in their internal database, and the feature in question is still in development, so it will most likely be fixed in due time.

Yeah, I hear ya. I was just trying to add information to maybe help them determine what might be causing it. I don’t know why that worked for me, it really makes no sense.

Hey Roblox! When will you fix this?
It’s been 5 days!

The Roblox Studio Developers Are Supposed to Fix This Bug.
Try Re-Installing Roblox Studios Or Update To The Latest Version.
Hope This Helps
Thank You!

There is no way to have an outdated version, since the update is always automatic.

1 Like

Still getting this error sometimes:
0.589.0.5890596_20230811T204834Z_Studio_6AF9E_last.log (187.5 KB)

Recently gotten this error, but it’s not consistent at all. Seems to have stopped now, but I cannot be certain it won’t come back.

It seems to have stopped for me as well. However, as I mentioned in the bug report, the problem is intermittent.

First run today, the problem is still there…
0.589.0.5890596_20230812T133623Z_Studio_B1E75_last.log (128.7 KB)

Hello, thanks for your reports.
We meanwhile have a fix for this ready to go in the next update.