Weapon animation with Motor6D

Hello. I am trying to make a sword animation, where the sword actually moves too. I have the sword bound to the right arm with a motor6d, but it still won’t animate. Am I doing this wrong? If so how can I fix it?

How it’s supposed to be :

How it is :

How I bound the weapon :

local RightArm = Player.Character:WaitForChild("Right Arm")
local Weld = Weapon.PrimaryPart:FindFirstChild("Handle")

local Motor6D = Instance.new("Motor6D")
Motor6D.Parent = RightArm
Motor6D.Name = "Handle"
Motor6D.Part0 = Weapon.PrimaryPart
Motor6D.Part1 = Player.Character:FindFirstChild("Right Arm")
Motor6D.C0 = RightArm.WeaponAttachment.CFrame * WeaponModule[WeaponType][WeaponString.Value].HandPosition

Did you by chance animate the sword with the Motor6D attached to the Weapon’s PrimaryPart?

1 Like

Yeah I did, I animated the animation with a clone of the exact sword and tried to replicate the motor6d properties that the clone also had.

Screenshot 2024-02-02 001943

For me, I haven’t done it using the handle. Maybe try unchecking “RequiredHandle” under tool and see if that works

1 Like

Sorry I seem to have found the problem, I had to switch these two around and it worked. Thank you for taking the time to give the answer though.

Motor6D.Part0 = Weapon.PrimaryPart <--
Motor6D.Part1 = Player.Character:FindFirstChild("Right Arm") <--
1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.