Weapon handle not working

Welp, weapons won’t work.

What do you want to achieve? I want the weapon to be hold by the player.

What is the issue? As you can see on the footage, the weapon shows up in only one spot to then fall down (while anchored it stays in one spot but won’t work anyway) and then completely dissappears from the inventory.

What solutions have you thought of so far? The model is downloaded from the model catalog, and i tried to mix it with the sword by roblox as the animations didn’t work before, so thats probably why it won’t work, but this handle part (unioned with other parts) is really pretty to me and i still want to use it.

Help? If i can, i will change the entire scripts, since they are probably broken anyway. I just want the union to still be the handle.

1 Like

Is the part anchored by any chance?

i anchored it in the second try

Try unachoring it and tell me the results.

First of all, you are receiving an error with the scripts, so I’m pretty sure this is a question for #help-and-feedback:scripting-support.

Second, are you able to hold the tool model?

1 Like

Try making a tool if you haven’t done so already.

watch the video i sent. in the first try i didn’t anchore it and it fell down, in the second it was anchored and was in one spot, without falling down, but still wasn’t hold.

Looking at the script, I see you added a script. Just put the part in a tool called handle.

it is a tool, it’s a handle object.

i called the part Handle, and its in the tool object. Did the video broke? :wut:

Does the tool have welds? If so, delete them.

Did you add a script to the tool? If so, send a screenshot of it.

I feel like this is the problem, i will try this out, thank you!

update: it still won’t work :frowning:

The part has to be called “Handle” and it has to be welded


I tried it without welds, worked perfectly fine.

A lot of handles need welds. Edit: Unless you don’t want the handle following u

1 Like