Weapons won't drop when 'backspace' is pressed

Yes the CannBeDropped box is set to true, but still when I press backspace it just re-equips the tool and nothing happens. What are methods I can use to make this weapon drop when backspace is pressed?

(I tried to parent the tool to workspace when backspace was pressed but it gave me the same result)


Three things:

  1. The gun cannot be easily dropped because it touches the player while dropping, hence welding too. If it’s welded to the player, you have to un-weld it.
  2. This thing also occurs on some specific Roblox gears.
  3. Script the gun so you can drop it properly, either by default CanBeDropped or alternative ways.

How to Fix It

  • Bind the backspace when the tool is equipped to un-welding the gun from the hands, if it has weld to it.
  • Avoid deleting welds that hold the gun together.
  • Avoid making the gun falling straight through the ground.
  • Avoid the collision to the player that causes movement disruptions.
  • Otherwise script it so it does something about it.

Why Is This Happening?

When a tool is welded to the arms, the result is usually that above in the gif. This causes the gear to be attached to the arm forever, until it is unequipped.

I remember very well that behavior to some official gears, pressing backspace with them usually result them getting stuck on your arms. It is not hanging there, it’s welded.

For some other gears, they don’t drop, they stay in backpack. That means they had the CanBeDropped false, and isn’t allowed to be dropped in any case.

Side note: This may not be the case, it’s my guess of what’s happening.
Side note 2: It is possible that animations causes this, but it is not consistent during the testing.