Weird behavior with Rthro

rthro

#1

I have been trying to use a custom character for my game, it did work out in another place but when I tried to use it in a place on its own, it did not work.
So far I have tried changing the hip hieght, using Rthro instead and using changing collisions.


#2

Are you manually changing its cframe every tick? Thats what this behaviour reminds me of.


#3

No indeed, that place is empty only with it and a script that welds armor to it. Here is a GIF with the HipHeight changed


#4

If it’s your place it is only working weirdly on, check the game configuration. Is it set to Rthro?


#5

Still, and this rig is in StarterPlayer and named StarterCharacter so it is a custom character not made out of welds


#6

Think this happens if the CollisionGroupId property of the character parts are set to a non-existent collision group.

Try setting CollisionGroupId to 0 on all parts.


#7

I feel so ashamed right now… I copied the model from the main game without thinking of that… Thanks for your help!


#8

That behavior can also happen if the HipHeight is set too small. You might want to try turning off automatic scaling if you are not using any of the scaling features.


#9

And for this?

All parts are massless and CanCollide = false except humanoidrootparts not massless.
Problem: They keep knock-backing each others.


#10

First guess would be that since the character has little mass, the forces moving the characters around are causing more bounce than normal. If you try increasing the density of the HumanoidRootPart, that may help.


#11

Worked out great, thanks.
I did try that before but it made the player accelerate when moving, I guess it was a bug.