Weird bug in one of the games I'm working on

So there are buttons in one of the games I work on on a phone like this:

but for some reason these buttons work on pc but not on phone so I tried this script and it still didn’t work is there something that I missed and why this wouldn’t possibly work?

This is the code I used to try some testing in studio with the buttons on the phone but it doesn’t output anything when playing with a phone but it does on a pc:


I have no clue why this doesn’t work like it has always worked for me like this and now it doesn’t.

Sometimes the Active property being false can be the cause of this. For example, when I was working with a text box: It worked on PC, but it was ignoring mobile users because it wasn’t Active. Very confusing. Maybe it’s the same type of thing for you?

sadly no I checked and the property is enabled but still thank you for your help.

Are you sure that the event is still being connected on mobile? Also, maybe there’s something covering the button and the Active property of that is the culprit?

Try using .Activated instead of .MouseButton1Click

some of them are disabled I’m trying to look if there are any more of them not sure but ty for saying that.

Still didn’t work I’m gonna try your method now.

I am pretty sure you are testing with the screen size tester, and I feel as that may be bugged. Why not test with an actual mobile device?

Still doesn’t work when using .Activated

okay I will try that now also I am trying to fix it like this because multiple people did report abt that game that it doesn’t work on mobile but it does on pc so ye.

Still doesn’t work on mobile I tried it rn.

I really don’t know what is wrong then. I mean I guess you could make your game pc only but that is probably the worst option. This still seems like a bug to me, maybe you could make a post in bugs? or wait until the bug is fixed (assuming this is a bug).

edit: by bug I mean a roblox bug lol

edit2: how many times have I said “bug” in this reply? lol

ye it’s a bug prob from roblox so idk what to do tbh and it’s weird cause it worked before like there are other button next to the phone and those do work

yeah, so I recommend waiting it out, and if that takes to long create a post in bug reports