Weird client side character glitch

So I’m running a game called Ultimate Hide And Seek (UHAS for short). There has been this bug since pre-alpha testing that the game simply can’t survive with. It’s where for some players someone’s character is going crazy like all over the place, flying everywhere and stuff like that. The bug where some people are glitching out only happens for the people who join after the first person does. But for the players who are glitching out for people, they say they are on the ground and all normal so this is obviously a client-side issue. I’ve tried looking this up but just it seems like nobody has had this issue, this is not a virus because I heavily scanned through my game and found no malicious scripts or weird data instances, etc. I do have a few possible suspects in this situation though, a client-side changes script. Called “ClientSideChanges” what it does is when the player is on like the hider team the client-side changes script (by the way it is a local script in starter player scripts) hides the lobby and shows the map. If you are out it hides the map and shows the lobby. If you are a seeker it shows the seeker room (the seeker room is where the seeker is teleported to let the hiders find their hiding spots) and the map and it hides the lobby.

Screenshots of this bug active:

Conclusion: It may be a virus, I’m not sure but I did just go through every free model in my game and found nothing suspicious.

Hit CTRL+SHIFT+F then search for require and string.reverse.

1 Like

Where should I hit CTRL + SHIFT + F like in workspace or the client-side changes script?

Oh nevermind, I only found 1 script that had the require and for the string.reverse I found nothing. But the script that had the require that’s the chat prefix script I made that is currently disabled.

It seems like the player’s character is parented somewhere else other than workspace, as testing this myself gave the same result.

Try searching for Parent, and see if any scripts does this.

1 Like

The character’s parent is in workspace 23190313813

Then it’s most likely a script that’s changing the transparency of the character model.
I don’t know what to tell you if this is not the case, as I have never seen this global issue before.

1 Like

Ok, thank you very much for your help.

1 Like

I had a similar problem in a game I was working on ages ago, I’m 95% sure it was caused by teleporting characters around by changing their HumanoidRootPart.CFrame instead of character:SetPrimaryPartCFrame().


Position is replicated automatically to the server from the client, I don’t believe that would be the case.
Most likely a global bug I can’t explain.

1 Like

In this case, I’m actually setting the CFrame of the HumanoidRootPart to teleport them to the map. And I’m doing it on the server-side.

I have this same issue with me and my friends game.


Yeah me and moreece have had this problem since one of my early games testing, we still have no clue what causes it

1 Like

Do you have adonis admin in your game?

I don’t have any sort of admin tools in my game.