Weirdly named parts inside of player's camera is breaking my mouse related scripts, possible backdoor?

So I recently made a script for my game with some mouse functions which worked fine at first but then I noticed it stopped working, having no idea why I decided to do print(Mouse.Target) and realized there is a transparent part with a random gibberish name blocking the camera. Every time a new server is started, the name of it is different (something like 276797b). Is this a possible backdoor? I tried to delete it but it would just undo the delete, when I looked for one of the names in my scripts I didn’t find any.image

1 Like

Search up ‘script’ in the explorer, and check for unwanted scripts.
If you use free models try this plugin: https://web.roblox.com/library/381046418/Server-Defender-OFFICIAL-PLUGIN
Good luck, and message me if this doesn’t work

1 Like

If you see something malicious, just delete it.
-RealisticWaves


Anyway’s could you show me your plugin’s, and there creator’s, I’ll see if you got the original plugin and not the malicious one.

I wish I could delete it but I have no idea where the source is from.

Here are my plugins and their creators:

Load Character Lite - AlreadyPro
Tool Grip Editor - CloneTrooper1019

Animation Spoofer - KYLETHORNTON (dont mind it, I only used it to easily transfer my personal animations to a group game)

AutoScale Lite - ZacBytes

Brick Cutter - Ozzypig

Brushtool 2.1 - XAXA

CamToCF - tyridge77

Hidden/Infection Script - Christbru01

Moon Animator - xSIXx

Part to Terrain - Fastcar48

Roundify - Stelrex

GapFill - stravant

ResizeAlign - stravant

Terrain Save and Load - sleitnick

ThreeDText2 - XAXA

uiDesign Lite - Stelrex

Thank you!

Sorry for not specifying, I meant a screenshot of all your plugin’s.

Thank you! I ran a scan with this plugin and within about 10 seconds it found the backdoor and successfully deleted it, thank you so much!

1 Like

And where was the backdoor located?

He never said he used any free model’s, so it’s most likely a plugin that’s causing this, so the malicious script/part in the workspace will most likely appear again when he restart’s studio.

That’s why I was asking, to let everyone know about where the issue was found. If it was a plugin then maybe report it.

1 Like