Weld not working

		local Katana = game.ServerStorage.Starter
		if Katana then
			local KatanaClone = Katana:Clone()
			local Weld = Instance.new('Weld')
			Weld.Part0 = KatanaClone
			Weld.Part1 = character:WaitForChild('RightHand')
			Weld.C0 = CFrame.new(0, 0, 0) + Vector3.new(0, character['RightHand'].Size.Y / 2,0)
			Weld.Parent = KatanaClone
			KatanaClone.Parent = character

No errors

1 Like

Your sword is Anchored and welds don’t work with anchored parts

Already tried having in unanchored and it ended up just falling through the map, thus being deleted

Have you tried a WeldConstraint.
They are a bit softer.

Doesn’t fix anything
30 characters

Don’t know how much of a band aid fix this is but I welded on CharacterAppearanceLoaded and that seemed to work.

1 Like

Doesn’t seem to weld in the correct psotion :confused:

That’s not the problem of this thread, create a new thread on how to position/rotate a weld.


Psst. Hey. One of my posts might interest you. They cover positioning, rotation and welding all in one. Hardly any work required from your end.