Welding Parts to handle causes weird player movement

So I have a sword tool with a Handle.
image

The “fxbox” holds particle emitters and other effects, it’s welded to the main handle via Motor6D.

The problem is when I equip the tool, I get weird player movement. Everything is unanchored. I tried using regular welds and WeldConstraint but nothing seemed to work.

https://gyazo.com/24e71782cb132cd52434b70b28ccdd98

I’m not an expert with welding but have you tried parenting the fbox to the main tool and then welding it to the handle

1 Like

Sorry if I didn’t elaborate, the fxbox is welded to the main handle, not the players hand.

That was a mistake on my end I meant to say handle

I tried it now and it doesn’t work

The sword doesn’t work or youre still have the same problem?

The same problem, when I moved the fxbox under the tool instead of handle, the player kept moving in weird directions

if possible can you send a video and did you turn off cancollide for the fxpart and handle

Can collide is turned off for both instances.
https://gyazo.com/24e71782cb132cd52434b70b28ccdd98

Remove the particle part from the tool so we can see if that’s the problem

I removed the particles and got the same problem

Can you show me all the children of the tool

If I remove the fxbox the sword behaves normally, so thats how I know the problem is with the part.

Try these:
Handle.RootPriority = -1
fxBox.Massless = true
fxBox.RootPriority = -2

Try removing the fxbox and the attachments maybe

I tested Masless and it works, thanks for the help @Sindious @KutayX7

1 Like

not a problem, I thought of that but I figured it wouldn’t make a difference

1 Like

@Interactivated and @KutayX7 as well.

It’s funny, I’ve seen a couple of posts just today about this same subject.

ANY TIME you add an object with mass to a Humanoid it affects the Humanoid’s physics. You have to make the Massless Property true for them not to affect it.

1 Like