What is the difference between game:getService and game:GetService()?

I have seen code using game:getService() and also saw scripts with game:GetService(). Is there any reason to use the other? I’m not sure if this is the right catagory but it is related to scripting so I believe it is. I have not seen anything on the devforum related to this.

The former is deprecated, the latter isn’t. In the older days Roblox adopted the camelCase naming convention, but later on decided to adopt PascalCase, and deprecated every camelCase member.

1 Like