What is this over my characters head, and how do I get rid of it?

A new thing appeared over my characters head.

It asked to access to my camera; I don’t have a camera.

I clicked: Deny Access.

Now it wont go away.

Screen Shot 2023-11-06 at 1.40.04 PM

Hi this is a Roblox feature which you can disable in your privacy settings:

Roblox is working on putting that icon somewhere else instead of above your head but that is still in works.

The reason of it being automatically enabled in your (what looks to be newly created game) was announced a few minutes ago right here:

I looked in game settings in Roblox Studio.

Both of those items you show above are disabled.

I opened a blank template and it still appears over my head.

The game it appeared within is not a new game. I have been working on that file for a very long time. More than a year.

1 Like

In that case go ahead and opt-out your game from having the camera feature implemented by going into Roblox Studio, in the top left click File, then Game Settings, then Communication and see if you have this disabled:

(This will disable the feature for all people using that feature in your game tho)

They are not enabled.

Fortunately, it only shows up in Roblox Studio.

It is not showing up when I play the published version.

In that case it might just seem like a visual bug in Studio? :thinking:
Or its for Developers to test how good / bad their UI works with the Roblox UI.

I don’t know; at the moment it seems to be broken.

I told it no, but it won’t go away.

When I click it a second time, it tells me it can’t access the camera. (Because I said. no).

Now I’m stuck with it, I guess.

Maybe they will fix it.

I don’t know if they can fix it because they might not even find that bug in first place.

I have just tried testing this by disabling my camera and microphone feature in privacy settings and in my game settings and I ended up not getting any bubble on my head:

Hey @mc7oof , I’m an engineer at Roblox working on this feature. Can you verify that “Enable Camera” inside the game setting is turned off and there’s a camera button over your avatar’s head?

In response to your question; I opened my game in Roblox Studio and clicked on Play.

The icon shows up over my head:

Screen Shot 2023-11-06 at 4.23.03 PM

I then re-published it and clicked on Play.

The icon was gone:

Screen Shot 2023-11-06 at 4.23.39 PM

I then closed the “published” file and re-opened it from my harddrive.

The icon re-appeared over my head:

Screen Shot 2023-11-06 at 4.26.35 PM

So it looked like it is only showing up in Studio when the file is not “published” and is being opened from a hard drive.

Sorry, yes. The feature is disabled in the published copy of the game.

Just a note:

I published the game again, then saved a new copy to the hard drive.

I opened the new copy. It still shows the icon.

I was thinking it would go away because the settings would be saved in the new copy. But, I guess not.

Got it. Apologies if it was unclear from the post, but only cloud-saved/published experiences opened from Roblox will respect the Camera game setting. For unsaved places, like the one you opened from a hard drive, it is expected to have the setting on since that is the default for newly published experiences now.

If this UI is in the way of your testing, I’d recommend saving to Roblox first. If you need to keep testing locally, we do have some upcoming changes that will soon allow you to hide the camera toggle so please stay tuned.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.