What's the deal with this animation?

Basic double jump script that plays animation on second jump, problem is the animation. It simply will not play. It seems to just be this specific animation, I tried a roblox dance animation it works perfectly fine. I even set the animation to Action4

Any help would be greatly appreciated, thanks in advance!
[Sorry for the noob question I rarely run animations]

Code snippet [no error in output]

		if character:FindFirstChild("Humanoid", true) and character.Humanoid.FloorMaterial == Enum.Material.Air and Can_DD == true then	--and didnt double jump already and has enough stam
			--double jump and sub stamina
			print("met requirments 4 double jump")
			Can_DD = false
			--subtract stam for jump
			local humanoid = character:FindFirstChild("Humanoid")

			local animation = Instance.new("Animation")
			animation.AnimationId = "http://www.roblox.com/asset/?id=14560460640" 
			local animationTrack = humanoid:LoadAnimation(animation)

                        print("double jump ended")
			Can_DD = true


Have you tried setting AnimationId using “rbxassetid://” ?

I have indeed. I’ve also forgot to mention it reaches every print aswell.

Hmm i think it have to do with animation RigType or Animation Owner but i think you own the animation so is the animation play with correct rig type?

1 Like

I think rig type may be the issue. I will try now if so I will be back to solution!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.