What's the max file size for a place before ROBLOX is unable to save or publish the place to Roblox?

Some notes:

  1. I want to know what the max file size before Roblox can’t / struggles to try and save your place and how to effectively save my place whilst still keeping a large terrain map, and also know the cause of the problem of being unable to save with giant terrain (using different places is not an option due to the intended feature of large maps).
  2. Despite having a powerful PC, terrain importation takes a while so I’ll use other’s screenshots which simulate my exact problem.
  3. Other people have posted the same question with terrain and max file saves but have come to no definite answer or the max seeming to be slightly above the file save of my save place.

Recently I’ve been messing around with how large I can scale imported terrain using QuadSpinner Gaea for terrain creation and TheNexusAvenger’s .OBJ importer as the best (I could find) and fastest OBJ importer that fits my needs. The scale feauture of the plugin allows you to resize the terrain to a high scale. I’ve found 16,000 makes the terrain its original size so I tried going for 12,000 and it worked. Though the terrain had a bit of holes that I could easily smooth out and fix, I tried “Save to Roblox” in which my output sent an error (following screenshot is not mine):
As you can see publish and save to Roblox failed, but saving to file is fine. I check the size of my place and woah, 197 Megabytes (207MB full size)
The size is so abnormal I can’t even upload the place file nor a roblox model file of the terrain here.

According to this post the max size for terrain is 16384x16384x16384 studs, which is much larger than my 12,000 scale.

I’ve tried a 10,000 scale which successfuly saved to Roblox only after a few tries of saving, however it did display the saving error mesage.

I’ve tried a 4,000 scale which successfully saved to Roblox with no hesitation. Why is my 12,000^3 (even less) 200MB terrain not saving despite under the supposed 16,384^3 studs limit? And what’s the max (or estimated) file size for saving so I don’t go through the nightmare of encountering this issue again?