When a mobile player clicks the TextBox their screen goes black?

I don’t even know if this is the right section for this but for some odd reason on mobile your screen goes black when you tap on the textbox and you are unable to see what you are typing in. I tried this out on the mobile emulator in studio but everything is working fine, it’s only happening on an actual device.
Any ideas on how to fix?

1 Like

I think it goes black for 2 reasons.
First one it could be the text of the mobile not loading.
And the second it could me a script error.
Hope that this helps you

There are no scripts in my GUI yet and I don’t know how I could fix the first one.

Just resize the gui to mobile users and PC Users

I think it’s a problem with putting a textbox in a scrolling frame, if I have the textbox in a normal frame it works properly.

Yes that’s the problem use a normal button and change the name.

its a textbox when the text is too long it wont fit on the screen thats why i need a scrolling frame, doesnt matter, i think its a roblox problem

Sounds like a bug on your device. Have you got anyone else to try and reproduce on their phone? If they’re not having any issues, you might want to try reinstalling the app yourself and see if that makes any difference.

Yep, happening on my iPhone X and my friend’s 7 Plus.

Strange. The only two things I can think is that maybe it’s an iPhone bug, or you have a fishy plugin installed.

Could you maybe post (or DM me) a link to the game, and I’ll try it out on my phone (Android)? I’ll see if I can reproduce it.

There should be a notepad button in the bottom left

It seems to be fine on my phone, but after playing for a minute all the UIs started glitching and tearing a little bit (including the CoreGui). My thinking is that the snow particles (or possibly something else) are using a lot of UI instances/memory which is causing this to happen.

Obviously this isn’t an issue for desktops, as they have a lot more processing power, but phones don’t quite have the same power to handle it. Try disabling your snow particle effect and see if that helps at all.

It’s happening in even an empty baseplate, I think it’s just a problem on IOS.
No one has reported UIs glitching out yet but I’ll lower the amount.

1 Like

Crashes, or like a gui on the screen?
you can disable the gui on the screen

neither, on iphones if there is a textbox in a scrolling frame and you try type in it, it will make your screen black until you finish typing

i think this is a roblox problem as i’ve had three people test it and i’ve tried it in different games

Just had this issue half an hour ago. I was setting scale (1) for the whole scrolling frame, but changed it to offset and it worked. Along with that, I set the Automatic Size property to Y.

1 Like

Thanks for replying, I’ll give that a try and see if it fixes it