When baking colorID map it comes out pitch black

Baking Textures

I’m in desperate need of help with baking.I’ve tried everything,watched countless tutorials but yet I failed.

What is the issue?
Well when i bake the texture it comes out black for some reason and it seems i can’t resolve the issue myself.I followed every step that Roblox(In Documentation) said to do(Different vertices not being in the same 16x16 area).

Keep in mind

Good to know is that I have a procedural material(GOLD)

Please help me resolve the issue and you will have my eternal gratitude.


1 Like

I used to have this problem, but it is very easy to fix. Where exactly you will find these settings will depend on what version of blender your using, but the two things you must do:

  1. Make sure metallic is set to 0. To bake the metalness map, set the roughness value to that of the metallic, and bake as a roughness map, but when baking, metallic should always be set to 0.

  2. In the bake setting, when making colour maps, make sure “Direct” and “Indirect” are disabled, and only colour is on. This means the engine will only account for the colour of the texture and not bake with the lighting. (I noticed you already have this corrected, but leaving here for anyone else who may have this issue)

Hope this helps! If it doesn’t work please let me know and I would be happy to help you work through it.

1 Like

I’m using Blender 3.4 right now.Was too lazy to upgrade to 3.5

1 Like

It seems it doesn’t work.

Posnetek zaslona 2023-04-18 162634
Posnetek zaslona 2023-04-18 162557
Posnetek zaslona 2023-04-18 162608
We can go to discord or PM for easier communication if you want.I personally don’t mind.

Tried with Diffuse as well and it doesn’t register the procedural material for some reason

Do you think it’s because of that
Posnetek zaslona 2023-04-18 164319

1 Like

I would disconnect all nodes except base colour, that may help. Also, I don’t believe you can use surface appearance for UGC items, I have never seen one using it but I may be mistaken, so everything else is pointless for a UGC item.

as it was already said, you can’t use surface appearance for UGC items. But to answer your question, you cannot bake the diffuse with a principled BSDF, you need to connect the color output to a diffuse node and bake instead.

One thing I like to do when baking in blender is to connect my maps one by one to an emmission shader and bake the emissive map. That way you don’t have to worry about these issues

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.