When editing a pivot, the edit pivot item on the ribbon toolbar is not highlighted while edit pivot mode is active

Problem

As stated in the title, when the edit pivot function is activated in the ribbon toolbar, it does not highlight to indicate that it’s active. The only way to tell is by the cursor in the viewport with the move and rotation constructs (see below image). This has been going on for awhile (since April 2024 I think), but I just got around to reporting it since it’s a minor issue.

EDIT:

I forgot to mention that this happens intermittently. Right after I posted this bug report, it mysteriously started working. But the screenshot below proves that it is happening.

EDIT:

I think I have isolated how to reproduce this. Before the first time Edit Pivot mode is engaged, the Reset option is disabled. However, when you engage Edit Pivot mode, then hit Reset, then turn it back off, everything seems to work normally, and you can now click Reset without having Edit Pivot mode on.


Additional Information

Parameter Value
Problem Area Studio
Problem Component Ribbon Toolbar
First Noticed Not sure, around April 2024 I believe
Priority Normal
Impact Low
Annoyance Level Moderate

The beta features that I have enabled are as follows:

  • Assistant Preview
  • Material Generator
  • Material Picker
  • Notched Screen Support
  • Texture Generator
  • Updated Docking System

As for plugins, I have a bunch that are installed, but very few are enabled. The ones that are enabled are listed below with links to their details page on the Roblox store website:


Expectations

What I expect to happen is that the edit pivot to be highlighted when the edit pivot mode is active.


Visuals


Reproduction

To reproduce the issue, perform the following steps:

  1. Open Studio and select the baseplate template.
  2. Create a part.
  3. Select the Model tab on the toolbar menu.
  4. With the part from step 2 selected, click Edit Pivot.
  5. Observe results.

Files

Not really.

2 Likes

This is just an acknowledgment announcement!

We’ve filed a ticket into our internal database for this issue and will start investigating, we will update you when we have further information.

Thanks for flagging!