When I jump in test mode it pauses rendering for debugging:

I know that this isn’t the right category for this, but I can’t post in Studio Bugs and this is driving me insane. Does anyone know a solution? Is this some hotkey issue I might have caused? I can’t have my player jump because it immediately pauses and stops rendering for debugging.

And yes I posted this here about a minute ago, deleted it because I thought there was a less specific dev support category.

1 Like

are there any breakpoints in your script(s)?

2 Likes

Yes, you can fix this

All you have to do is go to your studio keybinds and change the hotkey. If that doesn’t fix it, try clicking on the screen before pressing space


A few tips

Editing your post

You can move posts around (to topics you are allowed to access). Also, clicking the pencil button on your post allows you to edit it. image

Posting to other topics

You can post to any topic you want such as #platform-feedback:studio-bugs

All you have to do is use the post approval process to make a post there.

  1. Create your topic in the Bulletin Board category instead first. Make sure your post fulfils all the guidelines of posting in the category you actually want to post it in. Save the link to the topic.
  2. Then, put the link in a group message to Lead_Top_Contributor . Make sure to mention the category you want it moved to in the title.
  3. The Lead Top Contributors will then check your topic and move it to your requested category once it meets all the guidelines of that category.
1 Like

I’m having a issue similar to this. Whenever there is a line in my code that errors, Studio will say “Rendering is paused for debugging”. I have tried to turn off the lua debugger in my settings and this still occurs. Any ideas as to why?

1 Like

While editing a script go to “Script Menu” at the top. Then in the “Debug Errors” section, set to Never.

Sorry for bumping this topic back up, i have same problem and nothing worked any idea?

You may have one of these things:
image
You can click it to remove it

1 Like

Thanks, worked :slight_smile: (Ahh 30 char limit)