When player sets image through script it doesn't load

i made a booth game which the player can change text and the image, but when the player puts the image id, nothing happens?

show the code (char limitttttttt)

not much to show? all it is image.Image = "rbxassetid://0"

If you want to be helped, you must show it. We can’t help you if you don’t. We can’t say a specific solution is 100% effective for a problem if we don’t even know what type of problem it is.

the silly lil problem is that when the player sets the id (example: 9828069207) through the server, it doesn’t do anything? I have tried doing: "http://www.roblox.com/asset/?id="..tonumber(Icon) unless I need to set it through the client.

This is a common problem I also had previously. It occurs because the ID that the user puts in is not the real image ID behind the decal; it’s just the public ID of it.

More informations about ‘getting the real image ID from a decal’:



More informations about this problem:
.Convert Decal asset id to Image asset id

I believe you could fix it using 'http://www.roblox.com/asset/?id=(Id here)', but i don’t have Studio access to confirm it rn.

1 Like

alright your lil https://www.roblox.com/Thumbs/Asset.ashx?width=420&height=420&assetId= thingy fixed it thanks

1 Like