Why animations don't play?

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
    Animations playing when called.
  2. What is the issue? Include screenshots / videos if possible!
    the debugging is working fine, yet anims dont play for no reason
  3. What solutions have you tried so far? Did you look for solutions on the Developer Hub?
    Looking at other devforum posts, asking help in discord servers, changing code multiple times
function module.PlayAnim(animid, whatplay, speed, priority)
	local anim = Instance.new('Animation')
	anim.AnimationId = animid
	repeat task.wait() until anim.AnimationId == animid
	local loaded = whatplay:LoadAnimation(anim)
	loaded.Priority = priority or Enum.AnimationPriority.Action4
	repeat task.wait() until loaded.Length > 0
	print(loaded.Length, animid)
	loaded:Play(0, 1, speed or 1)
1 Like

could we see more? since if you tried “asking help in discord servers” then this shouldve been fixed but since it hasnt, there might be more

what do you mean by “more”?

more as in this context “more of a script or a different script”, i thought that was obvious

NVM, just solved it. I accidentally made the player play the anim of closet and closet play anim of player

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.