Why are my trees purple?

I have recently bought the following pack from synty studios:

I’ve been making a farm-themed map with it, but I’ve run into a problem with the trees.
While all the other assets are grey like normal:

The trees look purple!

Does anyone know why this might be happening, or how to fix it? All the assets are the same color and have no texture - but for some reason the trees still appear purple instead of the typical grey.


I don’t really know? Is the tree 2 meshes or just 1? If it’s 2 you can color them back to normal but I don’t know what’s causing this… Maybe if you just recently colored something purple on Studio, when you import a mesh to Roblox Studio it will color that mesh the same color you used last.

No, it is not the color property. These are the properties of the tree:image

It is a .fbx file, could it have something to do with that?

Possibly, but have you tried rejoining Studio? Sometimes I can’t color my meshes so I rejoin and it fixes itself. I always import things on .fbx, so that can’t be the problem.

Tried rejoining studio, still purple :confused:

SM_Tree_PolyPine_01.fbx (36.0 KB)

Here is the tree model, if that helps

Try to recolor it? It is the wierdest thing I have ever seen.

Recoloring it only mixes the color I want with purple. It’s like trying to recolor colored UI assets

Yeah, uhm. The tree comes up purple even on my 3D modeler viewer. It must have to do with the place you bought it from, otherwise I seriously don’t know, this is rather peculiar.

Well, in my studio the tree is purple as well. However, a warning message appeared when loading the mesh:

Could not find texture U:\Dropbox\SyntyStudios\PolygonNature\.....\PolygonNature.png. Please verify that the texture is located on that location, or in th same folder as the fbx/obj file


The tree must’ve been set to be purple.

Is there any way to remove the purple coloring in some sort of 3d model editor?

I guess in Blender. Texturing the color on, only thing I can think of right now.

1 Like

Opened it in blender and it’s grey! strange.

I don’t think you can import colored stuff from Roblox to Blender ensuring it stays colored. But, I could be incorrect. So, it being grey is by default.

It’s not from roblox, it is from the asset pack

I believe I found a fix for the issue. I uploaded the .fbx into blender, then exported into an .obj
The color must have been embedded somewhere in the .fbx file?

1 Like

Interesting. Well, good job. I would have personally never have thought about doing an .obj file.

For future references, the mesh has an image texture file that is “packed” or saved inside blender (which is read-only) instead of an external image file. The texture is no longer an image file format so when you load it in studio, it says “texture not found” though it still appears on the mesh and not in properties. When you need to import an fbx file into studio and come across this problem again, simply remove the materials of the mesh in blender then export as fbx.