Why are some meshes smooth and some are not? and how do i make them smooth?

so, i’m trying to make a frog model for my game, which so far had used a free model from the roblox toolbox. i made myself a more accurate model in a sculpting website, and when i imported it, there were too many polygons. i imported it anyway and i realized some mistakes on the model. so then i corrected it on the sculpting website and used another tool to reduce the polygon amount and i then imported it. the polygon count this time is a bit lower than the 10000 limit, but i noticed that it’s not as smooth as the free model and the previous one i made (the free model and the previous model didn’t have reflections on each and every single polygon, meanwhile the new one does). is it possible to make the new frog model smooth like the free model and the previous one? image attached below


new model on the left, previous model in the center and free model on the right (originally had texture but removed for clarity)


close up of new model


close up of previous model

i have tried changing the RenderFidelity but no change, i have tried re-uploading the same new model’s mesh a few times yet no change. anyone know how to make it smooth?

(also, any suggestions on how to texture the mesh? i tried using the same website but yielded low quality results. i dont have blender and i dont know how to use it (yet), any suggestions?)

1 Like

Its a feature of the 3D modeling software you use, and its called smooth shading. If you use Blender, there is an option to apply that to your model. There isnt a way to do this in Roblox, but doing it in Blender is easy.

1 Like

will the smooth shading also apply when the model is pasted to roblox?

1 Like

Yea, it will look just like the other models you posted.

2 Likes

alright i’ll go download blender and try it

1 Like

i tried it and it works! maybe i’ll also use blender for texturing the mesh

3 Likes