Why are there lines on my mesh?

(Blender Help)
When I’m playing in level 2 graphics or lower I get these lines in my mesh:

but when I play in level 3 graphics or better it looks correct:
2023-09-19 12_21_56-C__Users_Owner_Documents_ROBLOX_Rotation.rbxl - Roblox Studio

How do I remove those lines from the first picture?

Does the Mesh have Shade Smooth? It can be due to this. Try re-uploading the asset with Shade Auto Smooth.

I used Shade Auto Smooth.
Here is the Mesh:

Can you provide pictures of how the mesh looks with Graphics Quality as 2 to 10?

Furthermore, can you provide pictures of your Quality Level and Edit Quality Level? They are located at Studio Settings → Rendering

Is the experience open and/or uncopylocked? Perhaps I can try seeing if I can reproduce the issues by myself and come up with a solution… If that is okay to you :index_pointing_at_the_viewer: :slightly_smiling_face:

It seems that the experience is stating that the Roblox experience is private… Is it possible to set it to be public as well as able to play in cross-platforms such as Mobile?

Roblox automatically makes Meshes into Tris, but you have your mesh in Quads.
Did you select the end Faces and use the Shade Flat tool?

Select all your faces and go the the Face tab in Edit mode then select the Quads to Tris tool. This’ll show you how the tris will be placed. I’m betting the lines are from the edges of the Tris.

Also select all faces, go to the Mesh tab, and go to the Normals tool. There will be a drop down that has the option Reset Normals (or something like it, I forget what it might be called). This will recalculate the Normas for each face.


Thank you, this was bothering me for a while.

Before: Left
After: Right