Why cant players morph into a larger morph properly, but works when the parts are smaller?


#21

Does scaling a smaller character that already works up cause it to freeze?

And I’m talking about rogue welds attaching the character to unwanted parts. Not parts within the model.

Furthermore use Motor6D instead.

Additionally, I have made several suggestions that you have not tried in favor of fighting the people trying to help you. Please stop doing that.


#22

Removed all welds, still freezes.
Scaled up one of the other characters that work, and that one works.

So the issue is with my model. If that’s the case however, why then will the model work when I size it smaller?


#23

Are you able to post a file containing your model? I’m not home to look at it but maybe somebody else can.

As I’ve suggested several times now, have you manually checked each part for unwanted welds, and replaced existing welds with Motor6D?


#24

Is there a way that I could post the model without having it publicly available? I don’t want other people to take it.
And yes, I have removed all welds therefore all that is left in the model now is Motor6d.


#25

I’ll be home in 6 hours so if you haven’t solved the problem by then you can send it to me via private message I can take a look.

Also see previous reply.


#26

Ok, I will do that.


#27

Parts that are larger than roughly 6.3x6.3x6.3, when welded to a character (atleast with a standard 2x2x1 rootpart), cause glitching and various other issues. This also happens with other scales (10x9x4 probably would break as well), but 6.3^3 is the exact maximum cubic size I’ve found before you get issues. I did some investigating on this just over a year ago. Have you tried setting the parts to massless? If that doesn’t work, there are other ways to fix it.


#28

I have temporarily fixed the issue using a part that, when on touched, scales the R6 avatar to twice the size. Once you spawn with that, the faulty model works properly. However it’s just a temporary fix and does not count as fixing the actual issue with the morph.


#29

I wrote a plugin a while back that automatically fixes this issue in models. The one that is currently in my inventory is an older version. I’ll update it with my personal version and send you a link when I get home. If your model is set up how I expect it is, the plugin should apply an actual fix that won’t require humanoid scaling.

EDIT: You can install the plugin below. Once you have it installed, you can select either parts or a model and click “Remove Weight” to automatically scale part sizes and mesh scales to attempt to create the same visual with new part sizes that don’t cause problems. This only works if the parts contain mesh objects, and doesn’t work on unions/meshparts. Hope it helps!


#30

Hope these guys fixed it for you, but, if not, a work-around would be to keep it small, then make the rest of the environment extra small. Voila, a huge dino.

Life is all relative.


#31

After about an hour of trial and error removing everything in my game and testing it, I have found the solution to this issue, however it sounds completely surprising:

The solution was to delete all the old SpawnLocations and add in new ones.

Doing this has seemed to solve my issue completely. How? I’m hoping someone can answer this, because I’m really confused too.


#32

Did the old spawn locations have a joinable surface type while the new ones do not?


#33

They did not. I just encountered the same problem again but was able to solve it using my method. I encountered the issue just after I attempted to weld/rig a character in the same place that my game was in. This means that for whatever reason, it is getting attached to the SpawnLocation.