Why cant players morph into a larger morph properly, but works when the parts are smaller?


#1

So i want to know why when i have my model with the bricks at the usual default size, it won’t morph properly and ends up with the animations playing fine but the model is literally just frozen and wont move. Then when i resize all parts inside the model smaller it works fine.

Do humanoids or models have an issue morphing into parts of a certain size bigger? Because this is almost certainly the issue. If i size myself to 2 for example, then the original large model will load because it fits into this player to brick size ratio.

Here are the images:

So why is it that when i resize the parts smaller the player accepts the morph and does not accept the larger default sized parts?


#2

Make sure your HumanoidRootPart is proportional to the size of the character. If it’s too small it can misbehave. Your character may literally just be too heavy for the size of its rootpart.


#3

When you say proportional, should my rootpart be at least larger than my largest part to be sure?


#4

Think of it like a torso hitbox. It should fit within the main bulk of your character’s chest area.

You could also try toggling massless on a bunch of non-root parts now that that’s been released and see if that helps. I’m pretty sure the issue is with the weight of the character vs the force the rootpart exerts when you try to move. I think movement force has always been proportional to its size.


#5

I’ve tried massless before and I don’t think weight or mass is the issue because the character starts spawned in mid air and the larger morph only freezes in mid air but still plays animations. I’m convinced the issue is to do with the ratio between the size of the humanoid and the size of the model. If there was a script to resize an R6 I could solve the issue.


#6

I have large characters in my game that work fine. Please try changing the size of the rootpart.

Also what do you mean frozen mid air? Does this happen always on the large character?


#7

I just tried changing the rootpart’s size to this, which is bigger than any parts in the model, yet it still freezes in mid air. Should I make it larger? And yes, it always happens on characters with specifically large part sizes.


#8

Weird.
Ensure your parts have smooth surfaces and not studs and inlets. (Make sure they’re not welding to the baseplate)


#9

All parts are smooth, I think the only solution as far as i know to this issue is to do what I posted in the first part and make all part sizes 1,1,1 which I know to work, then just manually resize each mesh inside the part so that it looks like the original model again, the only difference this time is that the parts inside are all smaller.


#10

You should not need to do that. I have a large character of comparable mass in my game, so something else is wrong.

Can you try setting all part densities really low? Can you raise the rootpart off the floor and set Humanoid’s HipHeight? How are you testing the character?

Is it anchored?


#11

Just set all density and weight to lowest possible, still freezes on spawn. Rootpart raised, still freezes. I dont know how you would set humanoid HipHeight. It’s not anchored. I am testing this in studio.

One thing to note is that if I go in game and play, it will freeze. Then I say :Size me (any number) 2 for example. I am sized to 2, the character falls down from the sky and plays perfectly. Then i size me back to 1 and now the morph works perfectly. Only if sizing is used though, so it has something to do with the sizing thing.


#12

Are you SURE there are no rogue welds inside any parts of the model? Or inside the baseplate?


#13

I am using a welding script inside the model, however the other models that work are using this exact same script, plus i even removed the script at one point to test it and it still did not fix anything. The only conclusion I can draw from all the information available to me is that the part sizes are too large in my model.


#14

Why are you using welds in the character? You should be using Motor6D in all cases.


#15

To weld stuff like the eyes etc on to the head


#16

This definitely has to be an issue regarding your model or how you’re attaching it to the character, not the size of the parts you’re using. Humanoids are capable of supporting models well above their own weight (though the RootPart should be proportional to the model as mentioned earlier).

Between changing the size of the model and not, what other changes did you make at this time? How did either model behave? I feel like there is a very grim oversight being made here that’s causing this.


#17

Use Motor6D. Welds do not work properly with animation replication.

Furthermore double check for any rogue welds. I had a problem with my characters freezing on spawn and it was related to surfaces joining automatically.


#18

Well if I scale the model down to about 1/3 the size, it works perfectly with no issues present, so that might just disprove the issue of how I am attaching it onto the character.


#19

If you scale it up does it work? If you scale it by an extremely small difference does it work? Try scaling single parts one at a time until it works, then you can find the problem part.

Scaling it at all might be breaking welds. That’s why I’m insisting on this.


#20

Scaling does not break any of the welds because I can scale that working smaller version to any size except over a certain large size by which point it seems that it does not work. Even all my other morphs are all scaled relative to each other and they have had no issues. The only issues i have had with this freezing in the sky all come from a character that is very large,