Why do the parts of a character become invisible for a split, when welding a "Morph"?

I’ve tried to find out what could be causing it, by debugging it in many ways, trying many things out, but I couldn’t figure out the cause.

If you don’t know what I mean with, welding “Morph”, you could take a look at this script here R15 Morph Rig & Auto-Morph Script Tutorial because it is very similar.

I even tried using that script, and modified it a little bit so that it works with my testing “game”. But the parts of the Character that I tried to weld things to, still got invisible for a split second.

This only happens one time, then if I copy the morph and re-weld it with the use of a script, it doesn’t occur anymore. Atleast I think.

However, if I want to make it occur again, I just have to re-open the “game” in Studio and run the script.

Basically this is what happening

I have a Dummy.
Then I run the script that copies an instance of the morph and welds it to the character.

Then for a split second there’s a chance that this happens, while running the script

And after that, it is welded

Just note that this is not the thing I wanted to weld, that image is just here as an example. But the concept is the same.

I am actually not sure, what exactly has to be welded to a character, for it to be caused, but I this occured with MeshParts, and maybe it has to be a lot of parts, not sure.

Why do the parts of the character “randomly” become invisible for a split second and then it doesn’t anymore until you re-open the game in Studio?

The script could be adjusting the part’s position in order to weld them.

I’ve tried to modify C0 and C1 and Part0 and Part1, I tried putting the model really close to the player, and made it use the model that I copied in the workspace instead of a :Clone() however it still happend.

I tried to put wait() inbetween each property change, but I didn’t notice anything, it still caused to go invisible for a few seconds. Again this only happens once, then it’s like somehow “cached” or something.

I also notice that other experience have this issue as well, and some say it is a Roblox issue, though, I don’t have much more information about that.