Why does applying a humanoid description make the player glitchy?

I’ve spent so much time trying to find a answer but seems like i’m the only one to have this problem. I’ve tried so many things to make it work but none of them work. The glitch have no reason to occur, i’m losing my nerves.

Here the “glitch” : https://gyazo.com/4a98cabf5909549c21296c79fbf33cdd

I can’t walk, i just slide randomly for no reason. But at the moment i desactivate the script to apply the humanoid description, everything work perfectly.

Here the code, but i’m sure it should work.

local equipped = plr.Costumes.Equipped
local costume = script:FindFirstChild(equipped.Value)

I also tried with others humanoid description, but only humanoid description without a package seems to work. Here the properties of one of my humanoid description with a package :

HatAccessory = 15967866
BodyTypeScale = 0
DepthScale = 0.95
HeadScale = 0.95
HeightScale = 0.9
ProportionScale = 0
WidthScale = 0.9
Head = 134082579
LeftArm = 46359095
LeftLeg = 46359181
RightArm = 46359040
RightLeg = 46359241
Torso = 46358991
Pants = 1010915108
Shirt = 1649856129

It also look like a glitch of the “Farlands” but i tried a lot of place, like the point (0,0,0) and it still doesn’t work

I’m running out of idea, seriously, if someone have an idea, PLEASE help me, my game is ruined because of this.

Try increasing hip height of the humanoid?

im also having this problem, maybe make a script that changes the avatar itself rather than using description. there could be many other answers to this problem.