Why Does my animation not play when i use ContentActionService

I was making a abilty with ContentActionService and when i tried to play the animation when the ContentActionService was binded + keypressed it wouldn’t play at all.
here is my code

local Player = game.Players.LocalPlayer
local Character = Player.Character or Player.CharacterAdded:Wait()
local Humanoid = Character:WaitForChild("Humanoid")
local Animator = Humanoid:WaitForChild("Animator")
local Charge = tool:WaitForChild("Charge")
local ChargeAnim = Animator:LoadAnimation(Charge)

local function Move1(actionName,inputState)
	if actionName == ActionList[2] and inputState == Enum.UserInputState.Begin then

	Abilities.Parent = Player.PlayerGui

	Abilities.Parent = tool

the ContentActionService works find when i press the correct key but its just the animation.
keep in mind i just published this animation and had the priority set to action

it works with my Old animations but it doesn’t work with the new ones i create
idk if this a bug or just taking some time.


Where did you upload this animation? To a group?

no it was uploaded to my inventory, i guess thats what u call it.

Did you try printing above or under the ChargeAnim:Play() line?

yes everything works fine just the animation is not playing which i dont know why its literally my own animation to

Alright everyone i fixed it i apperently had to change it to Action2 for some reason or the baseplate i was using was broken. I just simply changed Baseplates and now the animations work fine! Ty all for trying