Why Does My Changes To These Towers Not Save?

Hey there so pretty much I’m making a Tower Defence kind of game and I was wondering why me editing these towers would not save after putting them into ReplicatedStorage. (These are test towers not the final towers lol)
So I’ve edited them into the workspace to look like this but when I play and place them in they look like this:
And then when I take them out of replicated storage and put them into the workspace this is what they look like:
Anybody know what the issue is here?

Do they look the same in play mode too?

Clearly they are the same models you started with. How are you saving them. If you’re editing them while testing you need to copy the ones on the workspace while testing then replace the ones they duplacate.

I’m not editing while testing im editing in an offline copy that I downlaoded and Idk why it’s doing this?

yeah it looks like the second one when i play and spawn them in

Hi, have you checked the scale properties?

I guess I’m not even sure what you’re asking … The scale is off? Check any meshes for size scale being off. Meshes also have a scaling value.

There aren’t any meshes inside it im confused as to why it’s doing this. Is it a studio bug possibley?

All the characters are made of meshes. It’s called “Meshpart”

so just check the scale and what would I change it to?

Inside every limb there is a intvalue called something with ScaleDefault. If you changed the size on your humanoid, you have to change the scale, instead of changing the size of the limbs manually

so I change the size of this?

First of let me clarify. Did you in any way change the size of your characters, while working on them?

I just used the scale tool to make them smaller so it fits with map of my tower defence game

I’ve not faced the problem before. Have you already tried with a new blank R16, and then scaling it down, and testing that?

Edit: I just did that, and worked correctly on my end. (cloned the gui from replicated to workspace through script)

1 Like

Hmmm does work must be something to do with script that places them want me to show it?

Yes please present the spawning/clone section. Also does your new blank R16 have the same issue as your other characters?

The main thing I find weird about this is the fact after I put it in replicated storage then take it out it isn’t to scale that I did 1 min ago. Scripts only work once game is loaded so im very confused could this be a studio bug?

Try see if the issue persists in a new studio world/game. I’ve had one issue lately, where when I inserted a character, it was cut in half. Only happened in a very specific studio world, even when it was a blank space.

Yeah so the dummy works fine but i’ll send through script now