Why does my tool disappear after about 10 seconds of equipping?

Exactly what the title says.

https://gyazo.com/d4b22acfd326705b1403246523bb02ab

image
Gun is in StarterPack.

AK_47.Equipped:Connect(function()
	local Grip = Instance.new("Motor6D")
	Grip.Parent = Character:WaitForChild("Torso")
	Grip.Name = "GunAttach"
	Grip.Part0 = Character:WaitForChild("Right Arm")
	Grip.Part1 = Gun.RArm
	local IdleAnim = Character:WaitForChild("Humanoid"):LoadAnimation(Animations.Idle)
	IdleAnim:Play()
	print("playing")
end)

Code in GunClient (LocalScript), I literally have no idea what’s wrong pls help. :sob:

3 Likes

The only possibility here is that the tool’s handle(and maybe other parts) somehow end up hitting the destroy height of the map. Or it could be a hidden script somewhere.

  • Look around a little for another script. Otherwise…
  • Try disabling(or remove code) anything related to animations and see if it’s the animations causing it.
1 Like

How is that even possible lol and what script could be doing that, like in a plugin?

Doubt it is a script, if you don’t find anything in workspace. It cannot be a plugin because I assume you can consistently “make your tool disappear in 10 seconds after equipping”. Remove the lines to animation playing and see if anything changes.

1 Like

Checked removing animation and just leaving the Motor6D, same thing, disappears after a few seconds.
Did CTRL + SHIFT + F and didn’t find any related scripts matching Backpack or StarterPack, nothing in my workspace as its a plain game so thats why I was confused.

This is not the first time this has happened to me, my tool has disappeared before randomly in another game and I do not know why, it’s only ever with THESE tps gun models.

https://gyazo.com/ab8c47dce9780cb186a6fc236348b8fe

Did you observe the explorer and see if all of it is destroyed in the process? If not, there might be a loose handle. Otherwise, can you provide other pieces of code you can find there? For drastic measures, disable plugins and try again.

1 Like

Nothing destroyed once game starts and I equip it.
Disabled all plugins, same result. I am literally going crazy lol.

I did a test and after it disappeared, took it out of StarterPack and put it in my backpack, equipped and unequipped and it was all normal! So I tried parenting it to the backpack in a script upon joining and it still disappears after being equipped. Very peculiar indeed.

Ok I’m really weirded out now, but it seems fine.

I selected all the model’s children, checked Anchored and then unchecked, checked CanCollide then unchecked and now it’s not disappearing and stays in my Character! Perhaps it was maybe 1 anchored or CanCollide part?

Thanks for your help mate. Hopefully now if I do this with the other models it’ll work fine.

That was really odd, I have no idea what but if you did mention that your character got stuck while equipping the tool it might be that. Hence you have to observe your character from the server to see if it’s actually stuck. In another note, are all the parts on the tool actually visible or are some of them transparent?

1 Like

After some further testing in two separate games, making the ALL the models parts unanchored but setting CanCollide to true fixes it, does not disappear. Since it’s an animation, my character doesn’t get stuck since its raised above the ground I guess?

All parts seem visible, nothing transparent other than 1 part which I set transparent manually.

While testing the tool, can you select the tool and see if the outer model outlines are expanding or not?

1 Like