Why does the part anchor it self after cloning

  1. What do you want to achieve? Keep it simple and clear!
    Im trying to make a fireball the projects from the player
  2. What is the issue? Include screenshots / videos if possible!

When I clone the part that is in replicated storage and parent it to workspace the part keep anchoring it self even though it is not originally anchored

  1. What solutions have you tried so far? Did you look for solutions on the Developer Hub?

I have browsed the devforum for answers to my problem but I have not found any solutions for this problem





Simply add something taht unanchored teh thing after parenting it to workspace

1 Like

you need to add

fireClone.Anchored = false

hope this helps!


btw I just noticed that it is anchored in the client but not anchored in the server

1 Like

I just tried what you told me but it still is anchored

CAN you give me solution please

Make sure it is unanchored on the server, in your remote handler script you can do fireClone.Anchored = false before you set its parent to workspace.

Also, I see you referenced workspace with game.Workspace even though there is a global for workspace simply called workspace. There is nothing wrong with this, but it just saves some time.

Just unanchor it when you fire it to the server…

I have found the solution for this problem and what I did is just instead of parenting it directly to the workspace I parented it to a Folder inside the workspace

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.