Why is Animation not firing?

You can write your topic however you want, but you need to answer these questions:

  1. What do you want to achieve? Keep it simple and clear!
    I want the animation to fire
  2. What is the issue? Include screenshots / videos if possible!
    When I mouse click the animation does not fire but when I unequip the tool and mouse button click at the same time it fires…
-- local drinkcoffeeevent = game:GetService("ReplicatedStorage").events.drinkcoffee

local player = game:GetService("Players").LocalPlayer
local debounce = false

		if debounce == false then
			debounce = true
			print("the pressed fired")
		--	drinkcoffeeevent:FireServer(player) <-- ignore this 
			local animations = player.Character:FindFirstChild("Humanoid").Animation
			local new =	player.Character:FindFirstChild("Humanoid").Animator:LoadAnimation(animations)

			debounce = false



	debounce = false

server script for giving the animations to humanoid
		local animation = Instance.new('Animation')
		animation.AnimationId = "rbxassetid://12770956899"
		local animator = Instance.new("Animator"):Clone()
		animator.Parent = char:WaitForChild("Humanoid")
		local new =  animation:Clone()
		new.Parent = char:WaitForChild("Humanoid")

it still does not work properly

My bad, add a print statement inside the MouseInput event. Tell me if the print activates or the already put in print statement fires.

the print does printout but the animation still does not play :confused:

Hm, I tested it, and it works pretty fine for me. There could be something wrong with the animation itself?

I think it could be because of my avatar

Have you tried it with a normal blocky avatar?

I have not tried yet with a block avatar

I’ll try right now to see if it works

I tried with blocky avatar like the one that is imported from Roblox and it works but not for the player

I am just going to redo the animation and see if it works. Thank you for trying to help though : )

whats the animation priority? sounds like it may be getting overwritten by the tool holding animation

how would I change the animation priority?

you can set priority in the animation editor, or in scripts via AnimationTrack.Priority. for example new.Priority = Enum.AnimationPriority.Action4

by default, animations are Core (lowest priority) so that may be why your animation isn’t showing

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.