Why isn't my car moving?

I was following the tutorial “How To Rig a Car” by @sleitnick and for some reason its not working. I have followed of what he had done but for some reason my car wont move. The turning works but I cant move. Please help me

Code Thats Not Working:

local cylFL = script.Parent.Chassis.CylindricalFL
local cylFR = script.Parent.Chassis.CylindricalFR
local cylBL = script.Parent.Chassis.CylindricalBL
local cylBR = script.Parent.Chassis.CylindricalBR

local function Update(dt)
	local throttleGoal = seat.ThrottleFloat
	throttle = throttle + (throttleGoal - throttle) * math.min(dt * seat.TurnSpeed, 1)
    local speed = seat.MaxSpeed * throttle
	cylFL.AngularVelocity = speed
	cylFR.AngularVelocity = -speed
	cylBL.AngularVelocity = speed
	cylBR.AngularVelocity = -speed


Hi, there are a lot of different things that could be happening. For starters, let’s check on these things:

  • Are all the parts unanchored? (probably b/c you can turn the wheels seemingly)
  • Do you even see the wheels budge a bit, or no movement at all?
  • Is the MotorMaxTorque high enough for the mass of the vehicle?
  • Does the output display any errors?

Hello, there aren’t any errors in the Output, it does seem to work only when you push it. I just made the car massless but then it just launches into space lol. I messed around with the MotorMaxTorque and it still the wheels wont budge. Okay I made parts massless and its still not working.

1 Like

If this helps idk @sleitnick

I have fixed it, turns out I forgot to set the Cylindricals to motor.