Why the player isn't moving with the seat?

Hey guys check this video:


I don’t know why this happens to me when I tween the boat and seat.

Here is the code:

local Players = game:GetService("Players")
local Player = Players.LocalPlayer

local campart = workspace:WaitForChild("Campart")
local proxypart = game.Workspace:WaitForChild("Part")
local proxy = proxypart.Attachment.ProximityPrompt
local boat = game.Workspace:WaitForChild("Boat")
local seat = boat.Seat

local cc = game.Workspace.CurrentCamera

proxy.Triggered:Connect(function()
	proxy.Enabled = false
	cc.CameraType = Enum.CameraType.Scriptable
	cc.CFrame = campart.CFrame
	seat:Sit(Player.Character.Humanoid)
	
	local destinationPosition = Vector3.new(-29.473, 12.764, 269.392)
	local tweenInfo = TweenInfo.new(
		5,
		Enum.EasingStyle.Quad,
		Enum.EasingDirection.InOut,
		0,
		false,
		0
	)

	local boatTween = game:GetService("TweenService"):Create(boat, tweenInfo, {Position = destinationPosition})
	boatTween:Play()

	local seatTween = game:GetService("TweenService"):Create(seat, tweenInfo, {Position = destinationPosition})
	seatTween:Play()
end)

Are you sure the seat isn’t Anchored and isn’t’ welded to the boat?

What happens if you wait 10-15 seconds when testing? It seems to me when testing my places that physics is one of the last things to load in.

If the boat is travelling in a straight line you could just use a PrismaticConstraint instead of a tween. That way any physics involved will move the player with the boat.

I am using TweenService, so anchored properties won’t do anything different, and the problem isn’t that the seat is not moving; they are moving the seat and the boat, but the player is not moving with the seat.


I tried to weld the player’s humanoid root part to the seat.
and also weld the seat to the boat, but nothing is happening.

You didn’t mention if you tried waiting 10 - 15 seconds. Maybe try a little longer just in case.

Like I said, PrismaticConstraints are great for this kind of thing.

Since you’re using tween service to move the boat, make a model and then parent the boat and seat to it. Then set the model’s primary part to the boat union, and in your script, tween the Model.PrimaryPart