Why this event isnt working?

Hi, my question is simple, why this isnt working

workspace.ship.PrimaryPart.Changed:Connect(function ()

I want to fire this, when primary part cframe change

1 Like

Hello yet again (lol)
You can use :GetPropertyChangedSignal to connect on a certain property changing, here’s how:

    print("The CFrame has changed!")
1 Like

And why isnt my code working??

There could be multiple reasons why, my only hypothesis is that it’s being fired too many times for it to handle (yes that can happen).

1 Like

not working…

I tested this in studio and it worked for me, are you certain that there’s a PrimaryPart?


main is a Model, you’ll want to change it to a singular part.

1 Like

no, main is part (in the same named model)

The event .Changed is fired only when a property of the “selected instance” changed.
It’s not working maybe because your instance (here main) not changing.
You also can’t use the .Changed event with a model for detect when the PrimaryPart change.

So you should just rename the PrimaryPart (and select PrimaryPart not by a property) :

workspace.ship.[Name Of The Part].Changed:Connect(function()

Make sure that you change model’s position with funciton SetPrimaryPartCFrame. This might be also useful if you are moving model from one distance to the other distance.
I hope this helps. :herb:


behaves just like a .Changed event, except you can modify it to connect to a function based on a certain quality of the object changing.

for example

If you insert a script with this code :
–We will suppose you have set a primary part for the whole model
, so then you can detect changes in the property of that specific part.

local part = script.Parent--primary part of the model

	function rotated()
	    print("the position of the part is " .. part.CFrame.Position)
	print(part:GetPropertyChangedSignal(CFrame) == part:GetPropertyChangedSignal(CFrame))

i tried this


but nothing

Maybe because nothing change. Try again with a script that change the CFrame

1 Like

I tried using


but also nothing

I dont know, but you are attempting to add a Vector3 and a CFrame. I vaguely remember that technically being ok, but try this:


Just, for be sure, try this (I don’t know if it’s working, I am very bad with CFrame) :

ok, but anyway, the cframe change (it go 100 up), but the event wont fire

Send a screenshot of what it looks like in the script, with the explorer open, showing where your script is, and screenshot the whole page.

It’s probably that the Changed event and the RBXScriptSignal returned from GetPropertyChangedSignal will not fire if there’s a change in position and cframe

You can use RunService.Stepped:Connect() to check to see if there are changes in its position

1 Like