Why Union Models is not appear?

Hello! i just want to ask… that why my Union Models in not appear in Roblox Studio ?
I tried : Reset All Settings 10 times
- Reset My Laptop 2 times

My Settings :

Please help me by the way reply this post :frowning: thank you so much.


Unions sometimes get corroupted, also why are you using unions for like a store, if you are not using them to make a brick with a hole, or using them to make moving objects, then you should not use them at all. Cause they take up more processing power to load than the same building with parts, and meshes, which is sorta bad for optimization.


This is a known issue. Hopefully, this will help you: How to recover invisible / corrupt unions


welp i used union to make roof for my school also i can not use Blender to creating meshes because my laptop is TOO WEAK :((


You would’ve been fine using Ctrl+G to group the parts together to create a model, it has about the same effect, also make sure everything is anchored too.


Blender has been getting better in terms of performance, if you aren’t rendering anything with it, you should be fine. I highly recommend using it for important stuff because unions can get corrupted.


When unions don’t appear it means one of two things, one it just hasn’t loaded in yet and could take sometime, usually exiting studio and then opening the place again does the trick, or two its corrupted and can’t load and you need to redo it!


You should use Union for making a hole and other stuff

1 Like

Welp… i tried and waited for more than 5 mins but still not appear.
I also tried save it to file, model and export it into roblox again :((

1 Like

It could just be a corrupt union then. It may be worth remaking it depending how complex it is!

1 Like

Do not use unions for normal blocks. Only use them for making holes etc.


@OBCBeeDev If you are experiencing this problem concistently, you should convert your models to meshes (OBJ Files or FBX Files)

1 Like

image it show me this ;( cri

@OBCBeeDev Then, if you can’t export OBJ files…
You could try separating your corrupted unions, simply separate your corrupted unions until they becomes fully visible, and then, re-unionize the union!

When you separate your union, you get back the old union data (this means that if you separate it, it will basically go back in time in the moment when you made it

1 Like

lol yes i did, i separated them each part and re-union them but still can, sometimes it take me more time i thought, i think i will re-start at the first time re-build the roof.
Oh and thanks for your reply, thank you!

I still don’t know how it doesn’t works, you always get back to the old union data…

Also, if you made your union in steps you could re-do thoos steps as well!

1 Like

This is what i mean with “steps”:

@OBCBeeDev Also if you don’t know how to separate a union, here is an example:



lol i did that step too!, i Separated them but it not appear like that, it just gone lol.

Well, i recommend you check your bandwidth, Unions are made with bandwith (i confirmed this trying to make a union without wi-fi connection, when i tried to make it, it simply corrupted) If your bandwidth is low, try to get a better internet connection

But if you got a bad bandwidth… i don’t know…
Maybe try 3D Builder ?

But before this, what are your pc specs?

1 Like

The unions are corrupted. Try to remake them in blender or just reunion them in studio.