Wielding / Instance.new() Help

***So im trying to make a prop game where you click a part and you turn into that object but i tried doing instance.new() and making a wield to the character but the part doesnt even want to attach to the player its currently 3:27 am and im losing my mind lol i need bad help not sure what im doing wrong its been a while since i came back into studio n done something but yeah i need help sorting out this issue? Video above and the code below :slight_smile: ***

local Module = require(game.ReplicatedFirst.ModuleScript)

local function Create(player)
	print(player.Name.." Has Fired")
	local Part = Instance.new("Part")
	local Weld = Instance.new("Weld")
	Weld.Part0 = Part
	Weld.Part1 = player.Character.HumanoidRootPart
	Part.Name = "Prop"
	Part.Position = player.Character.HumanoidRootPart.Position
	Part.CanCollide = false
	Part.Anchored = true

1 Like

You forgot to change the parent of the Part

Part.Parent = game.Workspace

can’t believe i forgot about that line but also how do i make the part wield to the character because currently with the script i got it doesn’t work?

1 Like

Never mind i figured it out thanks for the help though @VeriBaesix :+1:

1 Like

Whoops sorry I didn’t notice your edited question since no notification showed, make sure to mark a post as a solution so others would know it’s already solved.