Wierd shadows after unioning

image
Basically, I unioned a negated union with a union, and I got a few wierd shadows which kinda triggers my ocd, I’m currently using future for lighting.

1 Like

I literally hate this sometimes converting it into a mesh helps so horrible

1 Like

Go to properties, disable shadows.

1 Like

Yea you can just do CastShadow = false

Yeah I could try that but it might just make the lighting a lil worse, its always an option to just disable shadows.

1 Like

You should ALWAYS convert unions into meshes anyway, since Roblox has terrible CSG.

1 Like