Windows incorrectly docking in Studio, malformed windows

Before reinstall it worked when only 1 studio instance was running, but when second opened on second one it broke the same way as before (1st was still fine). After reinstalling everything if fixed. Thanks

That has never happen to me that must just be a Bug then!

Same issue as OP.

Let us work please. These releases are getting overzealous.


Unfortunately, no autogenerated logfile. How can I manually eject a logfile for the active session so I can catch this next time?

1 Like

I found a consistent workaround for the viewport becoming undocked from the title bar container

  1. Switch to the main studio window.
  2. Look for the title bar of your game, where all the tabs for scripts go.
  3. Click on this and drag it down with your mouse as if you are undocking it.
  4. The viewport should rejoin with the title bar.
  5. Now you should be able to redock the viewport by dragging it back to the regular docked position.

C.C @MrGreystone @Inf1n1tylt @dayflare @iiau

(P.s. I literally do not know how this problem exists, wackiest Studio bug I’ve ever seen, actually wild :flushed:)

4 Likes

This is consistently happening for me, however it only happens when I open a second studio. This is very frustrating as I often transfer assets between studios and multitask.

This somewhat works, however it makes the sensitivity extremely high and you’re unable to look up or down. Only arrow keys work.

Reinstall studio. It fixed it for me @4Slu

exact same problem. dont know how to solve

5 Likes

This is 100% reproducable upon opening my second studio tab
furthermore, It does not happen the first tab opened at all.

Primary laptop display in use. Moving to second monitor and opening the new tab opens the undocked viewport on the main monitor instead, always in the top left corner, just like when it is done on the main monitor (so monitor of focus does not seem to effect things).


Relisting specs for public:


Platform & Spec:

Manufacturer/ Model:

MSI GS76 Stealth 11UG-232

Specs:

OS: Windows 10 Home (fresh installation, fresh installed drivers from OEM)
CPU: Core i9-11900H @ 2.5 - 4.9GHz
Chipset: HM570
GPU: NVIDIA® GeForce RTX™ 3070 Laptop GPU (fresh installed drivers)
Video Memory: 8G GDDR6
Memory: 32GB (16G*2) DDR4 3200MHz
HDD Capacity: 1TB NVMe SSD (Interface: NVMe )

Full Source: MSI Website (see MSI GS76 Stealth 11UG-232)

Multiple Monitors (Laptop, HDMI cable to Samsung C24F390


2 Likes

I am still not able to reproduce this on multiple monitors and multiple sessions. Can you post a video of exactly what you are doing?

This is the same thing for me and I put a bug support message in and nobody has gotten back to me about it. Here’s my problem:

I’ve tried reinstalling, clearing cookies, and restarting my laptop and nothing is correctly working.

My specs:
``

|Processor|Intel(R) Core™ i7-4710HQ CPU @ 2.50GHz 2.50 GHz|
|Installed RAM|12.0 GB|
|System type|64-bit operating system, x64-based processor|

1 Like

I’m confused. This workaround should just get the window back to its default position, with the viewport back in the main window (though it apparently doesn’t work for everyone), I don’t understand how it changes DPI if it’s how it should’ve originally been.

@Inf1n1tylt Yep, because re-installing studio clears the files that store the layout properties (I’m not sure where layout stuff is located anymore unfortunately). This isn’t an ideal workaround imo because it resets all that. I like when my layout works.

@MrGreystone Very strange! I guess this workaround does not work in this case. Try clicking the actual place title, rather than the background bar?

@Bulldo344 I began experiencing this issue myself as well.

The layout seems to be in some sort of weird invalid state, each time play is started, all pinned windows flash, and all windows resize several times, which causes a lot of slowdown. It also resets the order of all pinned drawers (which is fairly annoying), and then eventually after some flickering and resizing it goes back to how it normally looks. I haven’t gotten around to reporting this properly yet but it seems that the layouts are quite complicated in their implementation, and seemingly weren’t designed very safely (or what they’re built on wasn’t) since a lot of these issues are entirely invalid states for the windows to ever be in.

@ElephantMesh Would the layout files themselves be beneficial to reproducing and fixing these issues?

I’d really like some info on how and where the layout information for all the windows (e.g. docked and pinned states) is stored, especially so I can try and understand why these issues happen for myself. I have experienced a lot of weird stuff where issues will actually even persist across studio restarts. That makes no sense to me, it suggests whatever is going wrong is also present in the file(s).

I feel like it’d also be beneficial to the people experiencing these issues to know exactly what files store the layout information, so they can reset the layouts, since these issues are completely workflow breaking. The viewport issue for example makes it impossible to use studio effectively, e.g if the viewport is off-screen.

P.s the detached viewport issue acts like the viewport is separate from the container, it behaves like any other floating window. The container itself (thing with the titlebar) behaves a lot like the pinned drawers, unpinning one unpins them all, so, my hunch is that it is using the same feature (like its a PluginGUI without a border, and placed inside a container), but there is some way to get the viewport into an undocked and floating state, but, with no titlebar, it can’t be docked again, or moved, or anything.

2 Likes

Try deleting Computer\HKEY_CURRENT_USER\SOFTWARE\Roblox\RobloxStudio from the registry. It worked for me with a problem with the old UI

1 Like

The only workaround I have is to manually dock Roblox Studio whenever it bugs out, and do that every single second. It’s very annoying and tedious to do everything every single second, and I just want this bug fixed. I’ve started to have this issue whenever this new docking update was first launched and I haven’t gotten a response back from bug support, a actual helping hand from Roblox Support all they have said for me to do is do the same thing I’ve been doing.

@SubtotalAnt8185 Is correct, the docking information is saved in the registry in that specific folder. Deleting that will reset your layout to the default.

We encourage you to report any bugs you see. Unfortunately, specific bugs have been challenging to track due to the fact that we are unable to reproduce them internally. This is one of the bugs that we are highly interested to track down, but have no reproduction of.

FYI: For this specific bug, thanks to the countless hours spent by our community, we have narrowed it down to having several sessions running along with floating widgets. You can effectively avoid it if you do not end a session with a floating widget, or only run one session of Roblox Studio at once.

@Bulldo344 Please DM me any bug thread that you have posted related to the docking update. Thanks!

8 Likes

Has been happening to me almost every time I’ve opened Roblox studio in the last 1-2 weeks, especially when I’m running 2 Roblox studio sessions at once. Really annoying since I frequently (literally all the time) run two Roblox Studio sessions at once due to my current project. Glad to see I’m not the only one experiencing this, hoping this gets fixed soon. :pray:

Continuing the discussion from Windows incorrectly docking in Studio:

Forgot to mention, sometimes instead of just the docking getting messed up, my camera bugs out and I can only move with my mouse in a circular motion. Also doesn’t let me look up or down, and then when I exit the tab and reenter, the docking bug occurs. Sorry if I didn’t explain that well but here’s a video (do keep in mind, this MOSTLY happens when I have 2 studio sessions running):

And then here’s a photo after leaving the tab and reentering:

When I go into a script, it sometimes stays on my screen permanently even when I go back to studio view. Text in scripts also turn fully white sometimes, and it stays like that permanently as well.

This happens to me every time I try to open more than one Studio client. Even a lone Studio client has plugins docking incorrectly in play mode or just randomly.

Not sure if this is the same issue, but Studio has literally become unusable for me without having to restart it every 5 minutes because the screen just goes completely white when trying to play-test it. This is a crucial issue that needs to be looked at and I believe it has something to do with the recent UI updates to Studio as it only just began occuring once they appeared for me.

Edit: Resolved as of the current time. I will edit this post once again if this issue occurs again.