Windows incorrectly docking in Studio, malformed windows

Reproduction Steps

I don’t know what caused it, but every time I go on studio now I see studio with a black screen for the world view and the world view in a separate window.


image

It’s extremely frustrating and I can barely develop with this.

Expected Behavior

It should dock as normal in the center.

Actual Behavior

The window appears at the top left of the screen. The tab however stays the same place.

Issue Area: Studio
Issue Type: Display
Impact: Very High
Frequency: Often

Edit: They still haven’t fixed it as of 10/31/22.

59 Likes

Try reinstalling Roblox Studio. If that does not work try restarting your computer. This happened to me when I updated Roblox Studio.

1 Like

I get the same issue, on windows if you have a monitor especially docking just doesn’t work and it goes unbelievably small.

I cannot post bug reports else this would’ve been filed ages ago.

It is frustrating to the point I stopped using the Official Studio Release and started using the RMM Canary Release.

4 Likes

Change your graphics mode to Vulkan.


I have windows and a monitor, but I can dock just fine. This must be due to the new UI update.

1 Like

It’s on Vulkan (just changed it) and still the same issue occures.

3 Likes

Change your DPI scaling to 100% and see if that fixed the issue.

Where do I find this setting? Is it in the studio settings?

1 Like

No. You need to go into application properties and go to compatibility. Then, click “Change high DPI settings”. Check the box next to “Application”. Click okay and then apply. Restart studio.

1 Like

It’s just broken it completely now.

1 Like

Change your DPI scaling in windows. Undo the change you made, and go to settings >Display. Click “Advanced scaling settings”. Enter 160 and then sign out when prompted. Open studio.

1 Like

Turns out because it was on extend it was messing up the DPI thing, I didn’t need to edit the windows settings, but I got it fixed now.

2 Likes

Roblox studio is literally unusable for me since yesterday. Every single time it opens up like this:

Image

For some reason scripts open like this:

Image

Like what is even this: Btw both scroll at same time and the one in normal studio window is unselectable.

Image

Double studio?

Image

Asset manager??

Image

Selection breaks

Video

Playtesting blocks whole left side with asset manager for some reason if asset manager is open.

Image

What even is this update. Can’t even make my game right now.

6 Likes

Yeah, I also sometimes get the small narrow script window instead of a tab with the other scripts
when opening a script from Find All.

Even stranger is that this never happened in the first several days of use of the new Studio.

1 Like

Studio was updating yesterday when I launched it. They broke something.

1 Like

Thanks! We are looking into this now. In the future, please post a separate bug report to ensure your post gets the relevant attention from staff.

3 Likes

I can’t post new bug reports even though I’m a dev forum member for 2 years. More info: I’m using 2 1080p monitors and have some studio windows undocked on second monitor.

We pushed an update. Can you do a fresh re-install, update, disable your plugins and check if you continue to face issues?

Still getting this bug as of version 0.545.395.5450470.

2 Likes

I have never seen that happen to anyone! That is a odd Bug to happen!

1 Like

Cant even post bug reports as the dropdown for severity refuses to actually show options, and it is required so cant even post.
Ill show it here, also related to this it seems you cant even edit scripts without the ui being buggy

Ever since icon change, studio has gotten extremely buggy, and it is really annoying

1 Like