“Inappropriate” DevProduct File Name

Hello! I am trying to make a new DevProduct for my game, however, every file name is considered “inappropriate”. If I try putting “hello.png”, it is apparently inappropriate. I have tried roblox.png, r.png, game.png, none of them work. I really need support on this and it would be greatly appreciated if you help me out. Thanks in advance!

Edit: Some file names like roblox.png worked once, then stopped working. I am currently unable to upload any DevProduct, no matter the name, because of this error.

Edit 2: The error seems to go away when a new DevProduct is created but remains with the old ones. And, yes, I am using the same image for both.

1 Like

Just wondering, why do you need the .png in your developer products? It could be the reason why its not working.

That is the extension. I didn’t include it in the actual name itself.

Can you delete it? If not I don’t I can be anymore help unless if you go to support on roblox
or if you just wait for another reply :neutral_face: Support

Unfortunately, I cannot. This seems like a website error unless ROBLOX suddenly decided to censor all of the English vocabulary.

1 Like

Must be moderation error due to .png being slapped on w/o permission

Nevermind, I managed to remove it, but with no succession.
Screen Shot 2020-03-14 at 9.04.32 PM

I don’t think it’s the extension’s fault. It might be something else, but I am not sure.

Maybe hard-refresh the tab. It might just be a slight error.

If you put X.png or X.jpg it will not accept it presumably because it has an invalid character. If you want it to pass moderation you have to rename the file to something without a full stop in it.

When you choose a file, check the name of the product itself, for example if you load file X.png, the product name will say X.png unless you change it.

Try renaming the file. It directly says that the file name is innapropiate

If they’ve rejected the exact image before, then they’ll auto reject it any time anyone uploads that exact image.

What does the image contain?

Alternatively try setting the file name to a regular word that isn’t related to “Roblox” or “hello”.

If you are trying to upload a image by browsing on the internet and comes up with a comment claiming its “Inappropriate” this could mean ROBLOX does not like it as ROBLOX could claim it is copyright and they could take action that it is “Inappropriate”.

ROBLOX would like it if it was blank but sometimes it could be vague depending on the type you want it but to make it more even interesting maybe roblox would accept if the image is un-copyrighted and it accepts it to be taken by browsing, It is highly suggested you could change the name of the (png, jpeg whatever it is called) e.g I was using paint3D, paintNET or photoshop I called it MyDesign.png, It may accept, If I browsed on Google or safari and I browsed “CashNote Icon” I drag it to the desktop and I rename it called “MyDevProduct1” and I submit it to the DevProduct it could identify it as “Inappropriate” image, I would advise if you specialise in design or you want to avoid copyright you could browse for it by identifying the browser it is not copyright, please make sure ROBLOX understands it as a suitable one.

If you have any questions, feel free to reply or if you found out its a specific type of a different error which might occur in this situation, feel free to reply and I will try my best to solve it as soon as possible if I try to find the best way of finding a resourceful matter why this could be happening.

If you miss-understand anything please feel free to reply and I will try my best to explain it.

I hope you found this helpful.



Im also facing the same issue. I different names for my image but nothing worked.
The .png didn show up in the upload dialog box.
I had the image named as 24gems.png and it threw error.
but I uploaded the same image to another dummy product that I had and it got uploaded. How is that?
Same name is getting rejected in one place and accepted in another.

Isnt there any guidelines for this?