100% of Stravant's plugins are broken

I don’t know what caused the issue, but Stravant’s plugins are seriously screwed up after an update some time ago. 100% of the time they freeze studio for 1/3rd of a second when selected before being activated, and seemingly at random the plugins break for different people. For instance, GapFill breaks for alertcoderf but works for me (still freezes studio on selected but it works after the freeze), while MultiMove is broken for me and works for other people.

Alertcoderf got this error in his output:
18:57:46.983 - Plugin_242796651.GapFill:693: attempt to perform arithmetic on field ‘1’ (a nil value)

I don’t get that error in my output.

I went to delete the settings folder, but there was none in his plugin’s folder: http://i.imgur.com/tWXhrdz.png

I’ve also noticed that settings frequently corrupt themselves. I have a plugin that saves any script under “Plugins” (http://i.imgur.com/pMEqZm6.png) to the main plugin’s settings, but frequently I’ll open up studio and find that the plugins object is empty and there is absolutely no settings file in InstalledPlugins for some reason. Confirmed on version and the latest release. On version they work perfectly fine and don’t freeze studio whatsoever.

The freezing happens because of plugin:Activate(). If I comment that out then the plugin doesn’t freeze.

What on earth are you doing? 100% of stravants plugins are working as good as the day I downloaded them. I’ve never updated them because there really wasn’t anything to update.

Are you using the most recent version of studio? Do they not freeze studio for a bit each time you try to open GapFill / ResizeAlign / NewDragger / MultiMove? What OS are you using?

Delete the 0 folder inside the InstalledPlugins folder. The settings are shared between plugins and some other plugin’s likely the culprit for breaking them - since it doesn’t happen for everyone. (Myself included)

I’ve tried that – that doesn’t solve the problem.

  1. Probably. If this just started happening today then I don’t know if it still works because I haven’t gone in studio all day.
  2. They don’t.
  3. 8.1

This has been happening for a while now – I’m using Windows 7 64 bit. Alertcoderf and IntellectualBeing, what OS are you using?

Spacek, I just uninstalled all of my plugins except GapFill and when I selected it studio didn’t freeze, but the FPS went from 60 to 30. Do you have any FPS monitors you could use to check what your FPS does when you select the plugin?

There’s a FPS monitor built-in.

Also, ResizeAlign works fine for me, GapFill is broken (same sort of error).

The only one of his that doesn’t work for me is GapFill, it just throws this error:
03:33:03.522 - Plugin_165687726.GapFill:71: attempt to call global ‘Deselected’ (a nil value)
03:33:03.522 - Stack Begin
03:33:03.523 - Script ‘Plugin_165687726.GapFill’, Line 71 - global Off
03:33:03.523 - Script ‘Plugin_165687726.GapFill’, Line 24
03:33:03.524 - Stack End
This is likely a separate issue though.

Oh, that? That has always happened, and it’s happened regardless of how man plugins I have. For whatever reason, it goes away once you select an edge (and same with ResizeAlign). It’s dependent on the complexity of the place and bricks in view.

EDIT: here, try these:

This is a recent issue that we’ve started looking into. Thanks for letting us know a few more details though!

The freeze ups appear to happen when a plugin creates GUIs. I notice it with the terrain tools.
As for the broken GapFill plugin, I have a fixed version here: http://www.roblox.com/Fixed-ResizeAlign-and-GapFill-item?id=264838065

1 Like

This appears to be back, I’m unable to use any of Stravants plugins, I’m getting the same problems that Echo posted in the OP.

1 Like

Also, a few people are reporting crash issues with my fixed version while using qCmdUtl in legacy mode, however I haven’t been able to reproduce.

I’ve recently been crashing every five minutes while using ResizeAlign, but I’m not if that’s due to a recent update or because I started developing on my laptop that has terrible hardware (ResizeAlign may have always crashed on low-performance machines and I never noticed it on my beefy desktop).

Resize algin has been crashing me these past few days too.

My laptop is medium high end though. Intel i5 dual(Sad face) core, Nvidia GeForce 645m, 8GB Ram.

I have a pretty decent desktop and ResizeAlign has been crashing me as well.

Well, that crashed the moment I tried to use the plugin, time to review this one.

1 Like