24 FPS Cap With Windowed G-Sync Enabled


This bug is very specific, and I only noticed now because I enabled the setting yesterday. Here are a few scenarios I have for my laptop:
G-Sync for Windowed mode is enabled and Roblox is focused: 24 FPS
G-Sync for Windowed mode is enabled and Roblox is unfocused: 60 FPS
G-Sync for Windowed mode is disabled: 60 FPS

Basic specs:
Intel i7 6820HK @ ~3.3 GHz with -125 mV offset
16 GB DDR4 2400 MHz
4K IPS Display with G-Sync

Screen Tearing on PC
Low framerate in play solo with Nvidia G-SYNC

I’ve had this issue before.

It may be overkill - but it’s worked for me before.


really unnecessary, just disable gsync in nvidia control panel for all applications, that fixed it for me
still a bug though from what I can tell


A recent post was closed as a duplicate of this post, which is why it’s getting necro bumped.

I tried to reproduce this issue last night but I was unable to. I have a Dell S2417DG 144Hz 1440p TN gaming monitor, and I use it configured at 1.25x scaling alongside an LG 4K display as a secondary (in 2x scaling). I’m on the latest version of Windows 10, Nvidia driver kept up to date by GeForce Experience. Can anyone running into this issue please provide detailed information about their setup? It seems like the OP has a 60Hz 4K G-Sync monitor, which is an unusual configuration. I tested these scenarios:

  • Roblox client fullscreen, G-Sync windowed mode off.
  • Roblox client windowed, G-Sync windowed mode off.
  • Roblox client fullscreen, G-Sync windowed mode on.
  • Roblox client fullscreen, G-Sync windowed mode off.

I didn’t try Studio with it enabled though.

Before I started, the option was off. I typically play games in fullscreen anyway so it didn’t matter much to me.


It was a problem for me with Roblox client windowed and G-Sync in windowed mode on. My laptop is a Sager NP8153 / Clevo P650RS. It will be about 2 weeks before I can test again because my laptop is going though an RMA.


Over the weekend I ran into the bug in Studio. I apparently had forgotten to turn off the G-Sync windowed mode setting.

I was able to resolve it by turning off the setting and restarting Studio.

I’ve done some quick google searches and it seems like this applies to other games, so I’m guessing this is a bug on Nvidia’s part. Some of the games which apparently hit the same issue (all of which are using different game engines):

  • Final Fantasy X Remastered
  • Fallout 4
  • Battlefield 3
  • Diablo 3
  • Heroes of the Storm

I also tried opening the microprofiler while I was hitting the issue. Present was taking 42 milliseconds, which is consistent with the graphics driver limiting us to 24 fps, rather than something in the Roblox engine itself.

Unless there’s something we can do on our end, it seems like it’s up to Nvidia to fix this. The good news is that the setting can be turned off without doing any harm, and it’s not enabled by default.


Turning off Vertical Sync in the NVidia control panel also fixed the issue I was having with Play Solo running at 36.4 fps while while studio was otherwise maintaining 60fps, on a PC with Nvidia Titan X Pascal card.