A few problems with this jeep

I’m working on a game where you play soccer using jeeps. We’re using a modified version of the classic jeep model:
Here are the problems:

  • Sometimes the jeep is unable to turn for 3-4 seconds. (there is no apparent cause for this)
  • The jeep will also slow down to 30-40 MPH, sometimes. (a few seconds after hitting the ball.)

Because the game is very competetive, this causes a very big problem. Players need to have full control over their jeeps at all times.

Quick note:
These issues happen to very few people. Most people don’t report problems with their jeeps.

Here’s a link to the jeep if you’d like to take a look at it:
Here’s the model for the ball:
If you have any questions, feel free to let me know. Thanks!

I’m no expert but u know how u hit players and it makes u lose speed maybe its the same with the ball.(for problem with slow down after hitting ball) so maybe u could try to change that in a script :slight_smile:

Thanks for the response! The ball is massless, so we don’t think it is causing the issue.

Has the jeep worked perfectly before? Do you have this problem only when others are also driving? Have you tested it by itself?

I believe its a network ownership issue, make sure to assign ownership properly for your vehicle…

See this roblox doc, scenario #2:

1 Like

someone improved the jeep model, this will most likely fix your problems

Thanks for the response. We tried this model but we found that there were some things about it that we didn’t like. Such as, the wheels are strange when driving over bumps.

Lemme look in to this, I think the jeep is already setting Network Ownership.

Yes, network ownership is working as intended:

1 Like

I think it might be something to do with this?

Thanks for the report! Can you send me a private message with a video showing the issue?

oh alright didnt take that into account nvm